summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-02-05 01:13:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-02-05 01:14:02 -0600
commit6ee833849a42dd8522248b993d7c33c072fde801 (patch)
tree59a6987a3735d9fbd2897adb2b847cf97cb7e2ef /app-emulation
parentapp-misc/neofetch: specify PREFIX explicitly (diff)
downloadgentoo-6ee833849a42dd8522248b993d7c33c072fde801.tar.gz
gentoo-6ee833849a42dd8522248b993d7c33c072fde801.tar.bz2
gentoo-6ee833849a42dd8522248b993d7c33c072fde801.zip
app-emulation/diskimage-builder: 3.7.0 bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-3.7.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 5f73f90772ed..fecbfbcc11b3 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-3.5.0.tar.gz 477918 BLAKE2B 0621a4af9bc68a19c45d88ddbe636ae3e6e86cc1668023b0f10020bff51929a03c12edfced248fc138a114ad4b538d7b71828ed44a5d18b54e39bd47919b9699 SHA512 bea42f47078966686af9774ef34300f326e2ddf4b536af53d1378cf413e6675df9f71c54d90fdb55fbdeeefc708264350a48d4a4b2824d0bc3263df04742d768
+DIST diskimage-builder-3.7.0.tar.gz 472703 BLAKE2B 4c3bf294f33556525f65d29e999cccaa4066d42f8e17742041666872ac01f5c6acab77d20b5d4281cc385a3f6988086e43c36f5330a656e5d2cb73c2e63e346d SHA512 c4453840f043774446e8dcb88bdc841d2fee8fb60432168fe48048171896932f2be9048fb0af9c5b777978218ec51f24bdfd6484a8e6cbe7a195b6df2508a1e1
diff --git a/app-emulation/diskimage-builder/diskimage-builder-3.7.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-3.7.0.ebuild
new file mode 100644
index 000000000000..4c39e9fb0b8c
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-3.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"