summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-12-11 09:07:05 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-12-11 09:07:05 +0100
commit709c059e1e9f78f14678b15fbd8129e31125905b (patch)
tree11f9fbe06468fbe082370eadaac491c6c8ef6a50 /app-emulation
parentapp-emulation/containerd: Version bump to 1.2.1 (diff)
downloadgentoo-709c059e1e9f78f14678b15fbd8129e31125905b.tar.gz
gentoo-709c059e1e9f78f14678b15fbd8129e31125905b.tar.bz2
gentoo-709c059e1e9f78f14678b15fbd8129e31125905b.zip
app-emulation/cadvisor: Version bump to 0.32.0
Signed-off-by: Manuel Rüger <mrueg@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.11
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cadvisor/Manifest1
-rw-r--r--app-emulation/cadvisor/cadvisor-0.32.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/cadvisor/Manifest b/app-emulation/cadvisor/Manifest
index 331cfacfa511..4780d930a81a 100644
--- a/app-emulation/cadvisor/Manifest
+++ b/app-emulation/cadvisor/Manifest
@@ -2,3 +2,4 @@ DIST cadvisor-0.28.3.tar.gz 4110487 BLAKE2B d6b9d6de67e5672a3ba57ea0c28f38e2e96e
DIST cadvisor-0.29.1.tar.gz 4152413 BLAKE2B 7eca61553f98a27b9d42f81618b67ebec2003c047557ea2bb749d0d36545c9c5ed76b67f8558ba335f396f16b6c496271875dd68b0d9f3554f92e20a63cc0cf5 SHA512 ce3a937607be2725388434cecb23ea8417bf3ddbd662cedcf128f090d52cc96c052dc016eeab32c34d3338fbb5b56091ee62720c32fb3313a5d41a556bc0b575
DIST cadvisor-0.30.2.tar.gz 4126305 BLAKE2B c0ded9a4e4d9f2942b2ae92dbc8037a4e6310686f82ff256dabdc6acc966b684621e213702ac97aac1648bd4dfcc6f757ce0c3a100b6830caa9d72e442a419c4 SHA512 415e89879c768d236dba1ad8a470b416406f53fc29d9654c011bf511b507c531e0be073c43110bba9c46f284a9235f76b743959f3363dcdc9d76a5631da530e2
DIST cadvisor-0.31.0.tar.gz 4604581 BLAKE2B b39cc3c2482353f1fb64ee0bb9baccdd310e6315819c21aaaef034970f39e2d6ffae05de4289b50838e8bad889f7d9a8e516768ba56a6854c76829a621e57554 SHA512 13b92c2148a439def2394232b3591c0367431f09f5998b5a79210e5b871e2986934fda8b1a3bbeb10691bb5b512556b76f32976b977005d767974c565bcf9072
+DIST cadvisor-0.32.0.tar.gz 4623510 BLAKE2B 7145d0224b3d64cd438bb94047d8682bcad842d7841d98f264a3118a2c0fabb7f67b183db80e054362428efc4f47c699692e53e651a14a1871cc3c32d3a0695f SHA512 734ad1f33e0948dba7e43a1695c3a96ce6bf4367a604b5b79f011c893e18ec697c48199ddb21edb7c176929ddd389e42de9b6f502a01c938c45612ffd96b5f5d
diff --git a/app-emulation/cadvisor/cadvisor-0.32.0.ebuild b/app-emulation/cadvisor/cadvisor-0.32.0.ebuild
new file mode 100644
index 000000000000..9442a3cae020
--- /dev/null
+++ b/app-emulation/cadvisor/cadvisor-0.32.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/google/cadvisor"
+
+inherit user golang-build golang-vcs-snapshot
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+COMMIT="8949c82"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+HOMEPAGE="https://github.com/google/cadvisor"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_prepare() {
+ sed -i -e "/go get/d" src/${EGO_PN}/build/assets.sh || die
+ sed -i -e "s/git describe.*/echo ${PV} )/"\
+ -e "s/git rev-parse --short HEAD.*/echo ${COMMIT} )/"\
+ src/${EGO_PN}/build/build.sh || die
+ default
+}
+
+src_compile() {
+ pushd "src/${EGO_PN}"
+ GO_FLAGS="-v -work -x" VERBOSE="true" GOPATH="${S}:$(get_golibdir_gopath)" emake build
+ popd || die
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dobin src/${EGO_PN}/${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+}