summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-04-19 12:37:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-04-19 12:37:20 -0500
commit7b9880a1e01b6d9ee7191d86024200aadd6bffc0 (patch)
treecd8ebca6ee9b06501973949886208fec279c1e18 /app-emulation
parentapp-emulation/cloud-init: 20.1 bump with py37/38 support (diff)
downloadgentoo-7b9880a1e01b6d9ee7191d86024200aadd6bffc0.tar.gz
gentoo-7b9880a1e01b6d9ee7191d86024200aadd6bffc0.tar.bz2
gentoo-7b9880a1e01b6d9ee7191d86024200aadd6bffc0.zip
app-emulation/glean: 1.17.0 bump with py37/38 support
Closes: https://bugs.gentoo.org/718210 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/glean/Manifest1
-rw-r--r--app-emulation/glean/glean-1.17.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/glean/Manifest b/app-emulation/glean/Manifest
index e9f14177af8b..117fa547e8d8 100644
--- a/app-emulation/glean/Manifest
+++ b/app-emulation/glean/Manifest
@@ -1 +1,2 @@
DIST glean-1.10.3.tar.gz 51898 BLAKE2B 95bcee5caae1bdcdc586c8d8ab8097b1dfaa35c521d7b90d128db14f496d4d31e1d0d4c540c4205861e5c7fa87d0e7038227ae9db0e898e3bf43b8b9b989e766 SHA512 27d4f29bf35585f73813e9efdea0253f0be3a8fa059c6ce524fbdd37b865d9c9e10d29bb8f970317ffe772c110cc76f10ae7debce5f7433461639dc63b9349db
+DIST glean-1.17.0.tar.gz 62791 BLAKE2B 6429bd721655499732f84dc8db4bd31bdb128289956ab65fab78ea5461cf7945ced893fd832ac6a3cdcedb331f3885004eaa530be1ee4fcc4168870b5c345dd3 SHA512 55c8ceae941296c038acff3f40cf4d6b783d7c6530ebd6fbd6d87938de11a1be1403741a559802c9135d3fc4d904b1936319dcf7a0179f95ac3f909667f5622c
diff --git a/app-emulation/glean/glean-1.17.0.ebuild b/app-emulation/glean/glean-1.17.0.ebuild
new file mode 100644
index 000000000000..521c8d3efe66
--- /dev/null
+++ b/app-emulation/glean/glean-1.17.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple program to write static config from config-drive"
+HOMEPAGE="https://github.com/openstack-infra/glean"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}