summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2018-11-24 10:14:06 +0100
committerTiziano Müller <dev-zero@gentoo.org>2018-11-24 10:15:20 +0100
commit82c03e208fc056e60ea1fda5dc7b797a488f404a (patch)
tree9093d21da4405b73c010e4a860dcfe4df730d76a /app-emulation
parentsys-auth/polkit: mark s390 stable (diff)
downloadgentoo-82c03e208fc056e60ea1fda5dc7b797a488f404a.tar.gz
gentoo-82c03e208fc056e60ea1fda5dc7b797a488f404a.tar.bz2
gentoo-82c03e208fc056e60ea1fda5dc7b797a488f404a.zip
app-emulation/libcacard: add patch to fix test failures
backported from upstream Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Tiziano Müller <dev-zero@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libcacard/files/libcacard-2.6.0-simpletlv-test-fix.patch31
-rw-r--r--app-emulation/libcacard/libcacard-2.6.0.ebuild4
2 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/libcacard/files/libcacard-2.6.0-simpletlv-test-fix.patch b/app-emulation/libcacard/files/libcacard-2.6.0-simpletlv-test-fix.patch
new file mode 100644
index 000000000000..40e2a9d21e26
--- /dev/null
+++ b/app-emulation/libcacard/files/libcacard-2.6.0-simpletlv-test-fix.patch
@@ -0,0 +1,31 @@
+diff --git a/tests/simpletlv.c b/tests/simpletlv.c
+index cd0cd69c4dfb504a52e3f7314e4a01657377eb68..9ddc5b999f73d56f35f85810479760b301330282 100644
+--- a/tests/simpletlv.c
++++ b/tests/simpletlv.c
+@@ -48,7 +48,7 @@ static void test_length_simple(void)
+
+ static void test_length_nested(void)
+ {
+- size_t length = 0;
++ int length = 0;
+ unsigned char simple_value[] = "\x12\x14";
+ static struct simpletlv_member simple[1] = {
+ {0x25, 2, {/*.value = simple_value*/}, SIMPLETLV_TYPE_LEAF}
+@@ -102,7 +102,7 @@ static void test_length_skipped(void)
+ static void test_encode_simple(void)
+ {
+ unsigned char *result = NULL;
+- size_t result_len = 0;
++ int result_len = 0;
+ unsigned char simple_value[] = "\x10\x11";
+ unsigned char simple_encoded[] = "\x25\x02\x10\x11";
+ unsigned char long_value[256] = "Long data value";
+@@ -168,7 +168,7 @@ static void test_encode_simple(void)
+ static void test_encode_nested(void)
+ {
+ unsigned char *result = NULL;
+- size_t result_len = 0;
++ int result_len = 0;
+ unsigned char simple_value[] = "\x12\x14";
+ unsigned char encoded[] = "\x72\x04\x25\x02\x12\x14";
+ static struct simpletlv_member simple[1] = {
diff --git a/app-emulation/libcacard/libcacard-2.6.0.ebuild b/app-emulation/libcacard/libcacard-2.6.0.ebuild
index 39e02adda5a7..a465af83fa18 100644
--- a/app-emulation/libcacard/libcacard-2.6.0.ebuild
+++ b/app-emulation/libcacard/libcacard-2.6.0.ebuild
@@ -18,6 +18,10 @@ RDEPEND=">=dev-libs/nss-3.13
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-simpletlv-test-fix.patch"
+ )
+
src_prepare() {
default