summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-12-30 17:08:57 +0100
committerManuel Rüger <mrueg@gentoo.org>2018-12-30 17:10:11 +0100
commit876d65362092bc427c14aa35cf4846f67e81d68b (patch)
tree4b31335268b21b59187ef694501f348bc80facab /app-emulation
parentperl-core/Math-BigInt: Remove old (diff)
downloadgentoo-876d65362092bc427c14aa35cf4846f67e81d68b.tar.gz
gentoo-876d65362092bc427c14aa35cf4846f67e81d68b.tar.bz2
gentoo-876d65362092bc427c14aa35cf4846f67e81d68b.zip
app-emulation/img: Version bump to 0.5.6
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/img/Manifest1
-rw-r--r--app-emulation/img/img-0.5.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
index ff6cb4ed5869..39c23fa5c17a 100644
--- a/app-emulation/img/Manifest
+++ b/app-emulation/img/Manifest
@@ -3,3 +3,4 @@ DIST img-0.4.9.tar.gz 4654821 BLAKE2B b3cd419aeb64ec8c2e8ee0fd523d387fd5b1a340ad
DIST img-0.5.1.tar.gz 6394095 BLAKE2B 5c26487f721ef7157c8dc47c5abc2f4f296efe4ddf3b4e1e0513e4a2a71c96287e92c2332b340d583f0687ff7c3b1f10aea107f9ab1527b3f6760f1f359de867 SHA512 66f812da0b77882a610f4de849eaf473a0a6e964fff7cc0b596b46411aa33d625a376d3e829b8eb438e26d09624146c18b83a2289ddf2785024e3f8a6fee6cf9
DIST img-0.5.2.tar.gz 3426613 BLAKE2B 75da804bee0960c195f3f5af6f10276d3d9a93dfcf08c784b831da2dd4e27714f0c8c24b24d2683b1b75276362b47a2bbc251e032b5b1b87c081922cee4f90f4 SHA512 cbae3fab61005238c939ad5fa5b785b07ee10f964a686962bdaec7170297840ebda188b93a1e3b89c6041db455a085d537005f8b1dc8753cd4e77f3e699f40e4
DIST img-0.5.4.tar.gz 3429272 BLAKE2B 3426dc6503693ad00c4c9f13c3813a6cf71826987aa2bb8351f695ffebed78fd79383b548040ef880b55984852f32fcb33ae5f1d1dcc4f9f6250498fbd64ebf0 SHA512 db51862aff5e0bb7280f17597f8d7231dd9aa741126b41c0af922b1f136d2ac4e0f08e51ab583ed098b194b58df29808c42cfd5381a217113f6b4bbf0dad06c8
+DIST img-0.5.6.tar.gz 3429213 BLAKE2B a1525d4aa09e11d122b41b54da8b90557dac3d0bfed5ea93dd6dad31269b7095d58d6d44dcd92dad9d56436132493d7ec8f1517b32eaa2bfb608bfb1fef639ec SHA512 e1a4469717df66f167f859cbf82ce54dd877e3e9c2f2d723f4424480c0429ac6ad99a13718c103bed3a823a91bef2f3ee3ac6c17e6f951f74f2f1b3ed0021785
diff --git a/app-emulation/img/img-0.5.6.ebuild b/app-emulation/img/img-0.5.6.ebuild
new file mode 100644
index 000000000000..acb7de2fa244
--- /dev/null
+++ b/app-emulation/img/img-0.5.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="d08b52517b4f2ec47e621541b8799de82c1a31f6"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}