summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-02-11 19:41:19 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-02-11 19:48:29 -0600
commit8ca3368317e4ce0fc7f559b041cc3adef96911d2 (patch)
tree1186a00176e3e6ea05d09c8390a9e01d57874a3b /app-emulation
parentapp-emulation/qemu: 2.11.0-r50: pin new firmware versions (diff)
downloadgentoo-8ca3368317e4ce0fc7f559b041cc3adef96911d2.tar.gz
gentoo-8ca3368317e4ce0fc7f559b041cc3adef96911d2.tar.bz2
gentoo-8ca3368317e4ce0fc7f559b041cc3adef96911d2.zip
app-emulation/spice: version bump to 0.14.0
- Update dependency on spice-protocol - Remove celt dependencu and only use opus... - Remove --disable-gui (spice does not have a GUI any more) - fix libressl support (Thanks to Michelangelo Scopelliti) - fix openssl1.1 support (Thanks to Mark Wright) - cannot reproduce static assert bug #634484 with gcc 7.3.0 Bug: https://bugs.gentoo.org/634484 Closes: https://bugs.gentoo.org/630142 Closes: https://bugs.gentoo.org/630594 Closes: https://bugs.gentoo.org/630942 Closes: https://bugs.gentoo.org/634696 Closes: https://bugs.gentoo.org/635864 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/Manifest1
-rw-r--r--app-emulation/spice/files/spice-0.14.0-libressl_fix.patch13
-rw-r--r--app-emulation/spice/files/spice-0.14.0-openssl1.1_fix.patch26
-rw-r--r--app-emulation/spice/spice-0.14.0.ebuild100
4 files changed, 140 insertions, 0 deletions
diff --git a/app-emulation/spice/Manifest b/app-emulation/spice/Manifest
index 0062f85f984a..5dd45f8f0fc4 100644
--- a/app-emulation/spice/Manifest
+++ b/app-emulation/spice/Manifest
@@ -1,2 +1,3 @@
DIST spice-0.13.3.tar.bz2 1322505 BLAKE2B 56f9cd34bb48fdcf750230242b27567db713ef749649d4b780a82d0d4ec5d326b19540c9bb4f36c164d40a692eb0368c39e05ee8dba319dd8461a0315e5a9a17 SHA512 63496fbd3df0fd453052cef8e1fb00a3a28f0105610676fdc4a58043cbc6da571ae4407701af2b817e410d05ce727d60d5ee0c93c8897231e25229897c51d95a
DIST spice-0.13.90.tar.bz2 1364173 BLAKE2B 1bc0e71d8c5a21f9961ac6c0567bde19d31983bd5b0f5d4df30cc5634080d288f277689d875334d94c6a276284313bc82f15eaf0ce20916c6c912c2dcc4bdfc0 SHA512 a5a6ab328a2d3cb405ead6eef40a1b896432f35accf1f8b015fc9deadcc4e5eb5f6d8d575a94fa3b2505e206986887badecf721ab015efd88dad174d7340c01c
+DIST spice-0.14.0.tar.bz2 1330195 BLAKE2B 08f93e8ddeb79adb4feac0557a854cc41fd096a9dfefc0baaca176803c2a03ef9286c4f61a135d62ad22e3ac3f4bb31ffd1614c8ddeaec7ae8c01eca34da1750 SHA512 84532146aa628ca6ca459a82afb89d6391892e063668fd4a68023c92cee7ca868b6c82e31dd9886819b76ea745ebdae0d0030e1f608d8f58f51c00f0b09bae1f
diff --git a/app-emulation/spice/files/spice-0.14.0-libressl_fix.patch b/app-emulation/spice/files/spice-0.14.0-libressl_fix.patch
new file mode 100644
index 000000000000..2f77fa5a0006
--- /dev/null
+++ b/app-emulation/spice/files/spice-0.14.0-libressl_fix.patch
@@ -0,0 +1,13 @@
+diff --git a/spice-common/common/ssl_verify.c b/spice-common/common/ssl_verify.c
+index a9ed650..27aa5d3 100644
+--- a/spice-common/common/ssl_verify.c
++++ b/spice-common/common/ssl_verify.c
+@@ -33,7 +33,7 @@
+ #include <string.h>
+ #include <gio/gio.h>
+
+-#if OPENSSL_VERSION_NUMBER < 0x10100000
++#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined (LIBRESSL_VERSION_NUMBER)
+ static const unsigned char *ASN1_STRING_get0_data(const ASN1_STRING *asn1)
+ {
+ return M_ASN1_STRING_data(asn1);
diff --git a/app-emulation/spice/files/spice-0.14.0-openssl1.1_fix.patch b/app-emulation/spice/files/spice-0.14.0-openssl1.1_fix.patch
new file mode 100644
index 000000000000..ea4e606b3db2
--- /dev/null
+++ b/app-emulation/spice/files/spice-0.14.0-openssl1.1_fix.patch
@@ -0,0 +1,26 @@
+--- spice-0.13.90-orig/server/reds.c 2017-07-27 01:04:10.000000000 +1000
++++ spice-0.13.90/server/reds.c 2017-10-18 21:42:12.054934199 +1100
+@@ -34,6 +34,8 @@
+ #include <ctype.h>
+
+ #include <openssl/err.h>
++#include <openssl/bn.h>
++#include <openssl/rsa.h>
+
+ #if HAVE_SASL
+ #include <sasl/sasl.h>
+@@ -2795,9 +2797,12 @@
+
+ static gpointer openssl_global_init(gpointer arg)
+ {
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ OPENSSL_init_ssl(0, NULL);
++#else
+ SSL_library_init();
+ SSL_load_error_strings();
+-
++#endif
+ openssl_thread_setup();
+
+ return NULL;
+
diff --git a/app-emulation/spice/spice-0.14.0.ebuild b/app-emulation/spice/spice-0.14.0.ebuild
new file mode 100644
index 000000000000..11420b4ea1be
--- /dev/null
+++ b/app-emulation/spice/spice-0.14.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit autotools ltprune python-any-r1 readme.gentoo-r1 xdg-utils
+
+DESCRIPTION="SPICE server"
+HOMEPAGE="https://www.spice-space.org/"
+SRC_URI="https://www.spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="libressl lz4 sasl smartcard static-libs gstreamer"
+
+# the libspice-server only uses the headers of libcacard
+RDEPEND="
+ >=dev-libs/glib-2.22:2[static-libs(+)?]
+ media-libs/opus[static-libs(+)?]
+ sys-libs/zlib[static-libs(+)?]
+ virtual/jpeg:0=[static-libs(+)?]
+ >=x11-libs/pixman-0.17.7[static-libs(+)?]
+ !libressl? ( dev-libs/openssl:0=[static-libs(+)?] )
+ libressl? ( dev-libs/libressl:0=[static-libs(+)?] )
+ lz4? ( app-arch/lz4:0=[static-libs(+)?] )
+ smartcard? ( >=app-emulation/libcacard-0.1.2 )
+ sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=app-emulation/spice-protocol-0.12.13
+ virtual/pkgconfig
+ $(python_gen_any_dep '
+ >=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ')
+ smartcard? ( app-emulation/qemu[smartcard] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libressl_fix.patch
+ "${FILESDIR}"/${P}-openssl1.1_fix.patch
+)
+
+python_check_deps() {
+ has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
+ has_version "dev-python/six[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Prevent sandbox violations, bug #586560
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ xdg_environment_reset
+
+ local myconf="
+ $(use_enable static-libs static)
+ $(use_enable lz4)
+ $(use_with sasl)
+ $(use_enable smartcard)
+ --enable-gstreamer=$(usex gstreamer "1.0" "no")
+ --disable-celt051
+ "
+ econf ${myconf}
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #586560
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ default
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}