summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-22 18:10:25 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-22 18:13:53 -0700
commit96f4dd5cf85d06d03d91d5d31bf1e3f78b9a6833 (patch)
tree7726442f46e8f117870f8e8eb38c77eef00b53bf /app-emulation
parentx11-libs/libX11: Drop old versions (diff)
downloadgentoo-96f4dd5cf85d06d03d91d5d31bf1e3f78b9a6833.tar.gz
gentoo-96f4dd5cf85d06d03d91d5d31bf1e3f78b9a6833.tar.bz2
gentoo-96f4dd5cf85d06d03d91d5d31bf1e3f78b9a6833.zip
app-emulation/crun: add ~ppc64 keyword
and fix QA issues app-emulation/crun/crun-0.14.1.ebuild: line 41: Ebuild contains assignment to read-only variable and unquoted paths Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/crun/crun-0.14.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-emulation/crun/crun-0.14.1.ebuild b/app-emulation/crun/crun-0.14.1.ebuild
index 998223b4abf8..651d5f88be89 100644
--- a/app-emulation/crun/crun-0.14.1.ebuild
+++ b/app-emulation/crun/crun-0.14.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
-KEYWORDS="~amd64 ~arm64"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
IUSE="bpf +caps man seccomp systemd static-libs"
DEPEND="
@@ -38,14 +38,14 @@ DOCS=( README.md )
src_unpack() {
# dont' try to unpack the .lds file
- A=( ${A[@]/libcrun.lds} )
- unpack ${A}
+ MY_A=( ${A[@]/libcrun.lds} )
+ unpack ${MY_A}
}
src_prepare() {
default
eautoreconf
- cp -v ${DISTDIR}/libcrun.lds ${S}/ || die "libcrun.lds could not be copied"
+ cp -v "${DISTDIR}"/libcrun.lds "${S}"/ || die "libcrun.lds could not be copied"
}
src_configure() {