summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2019-04-06 22:58:19 -0500
committerErik Mackdanz <stasibear@gentoo.org>2019-04-06 22:59:23 -0500
commit9f332cec5f85e5048c478e9586dcb669032a186c (patch)
tree10484f5c45d517419d312da5b84e2c7792030b5a /app-emulation
parentx11-plugins/wmweather: amd64 stable wrt bug #681126 (diff)
downloadgentoo-9f332cec5f85e5048c478e9586dcb669032a186c.tar.gz
gentoo-9f332cec5f85e5048c478e9586dcb669032a186c.tar.bz2
gentoo-9f332cec5f85e5048c478e9586dcb669032a186c.zip
app-emulation/lxd: bump to 3.12
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Erik Mackdanz <stasibear@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/lxd/Manifest1
-rw-r--r--app-emulation/lxd/lxd-3.12.ebuild241
2 files changed, 242 insertions, 0 deletions
diff --git a/app-emulation/lxd/Manifest b/app-emulation/lxd/Manifest
index d48b9ba3565e..5c445c18e2c5 100644
--- a/app-emulation/lxd/Manifest
+++ b/app-emulation/lxd/Manifest
@@ -1,2 +1,3 @@
DIST lxd-3.10.tar.gz 27057432 BLAKE2B b5a5c3cd4f1045419c806510aab21c3bcde8c8687ede808b1b832e2a0caba0ff3af5d79367141b29e84c0bd3bcf6958d917bc813700220e238cd21933963009b SHA512 25ed7675af7b6861d754607b19485e329ae344befac06fe33f326e34030755359bea6f574c414849b85f034533fd5dccb95a326ae0ad9e44b8ea366f7ee44d04
DIST lxd-3.11.tar.gz 27281796 BLAKE2B 640944cd929b69b7c6f935b7e3587e05b77ec71da8f20b988b831b837f86706b3cb3a81676f4ae456bf06594ea74e9ab44b87d22ddaa78209d4a0f6cbbba3483 SHA512 182a2fd6b69c8228760c26498d77f46c6bdda899018e1ab4470f2382202250582c66fc11f4c2d8d86598f19e3a62a1027dfe190342611c4a819a27ce6e39e78e
+DIST lxd-3.12.tar.gz 27365315 BLAKE2B 2b371ef4e9703a7a0494ca009b3c04a3051d76ba0bc87566b90871059cce04f80c5d941d639a53762b219f658379bbffb8ed844cee4271bb756aecb2742ce1d0 SHA512 fd56ee2a2114b338cfb8b575775530b34c7dcc978c95f9bc3b0dced91cf7f01558012c357eb3f8220bc6fa6aa5ecaca67d47b300b67c0d193f11c5088ce6330e
diff --git a/app-emulation/lxd/lxd-3.12.ebuild b/app-emulation/lxd/lxd-3.12.ebuild
new file mode 100644
index 000000000000..988a505aa241
--- /dev/null
+++ b/app-emulation/lxd/lxd-3.12.ebuild
@@ -0,0 +1,241 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Fast, dense and secure container management"
+HOMEPAGE="https://linuxcontainers.org/lxd/introduction/"
+
+LICENSE="Apache-2.0 BSD BSD-2 LGPL-3 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+daemon +ipv6 +dnsmasq nls test tools"
+
+inherit autotools bash-completion-r1 linux-info systemd user
+
+SRC_URI="https://linuxcontainers.org/downloads/${PN}/${P}.tar.gz"
+
+DEPEND="
+ dev-lang/tcl
+ >=dev-lang/go-1.9.4
+ dev-libs/libuv
+ dev-libs/protobuf
+ nls? ( sys-devel/gettext )
+ test? (
+ app-misc/jq
+ net-misc/curl
+ sys-devel/gettext
+ )
+"
+
+RDEPEND="
+ daemon? (
+ app-arch/xz-utils
+ >=app-emulation/lxc-2.0.7[seccomp]
+ dev-libs/libuv
+ dev-libs/lzo
+ dev-util/xdelta:3
+ dnsmasq? (
+ net-dns/dnsmasq[dhcp,ipv6?]
+ )
+ net-firewall/ebtables
+ net-firewall/iptables[ipv6?]
+ net-libs/libnfnetlink
+ net-libs/libnsl:0=
+ net-misc/rsync[xattr]
+ sys-apps/iproute2[ipv6?]
+ sys-fs/fuse
+ sys-fs/lxcfs
+ sys-fs/squashfs-tools
+ virtual/acl
+ )
+"
+
+CONFIG_CHECK="
+ ~BRIDGE
+ ~DUMMY
+ ~IP6_NF_NAT
+ ~IP6_NF_TARGET_MASQUERADE
+ ~IPV6
+ ~IP_NF_NAT
+ ~IP_NF_TARGET_MASQUERADE
+ ~MACVLAN
+ ~NETFILTER_XT_MATCH_COMMENT
+ ~NET_IPGRE
+ ~NET_IPGRE_DEMUX
+ ~NET_IPIP
+ ~NF_NAT_MASQUERADE_IPV4
+ ~NF_NAT_MASQUERADE_IPV6
+ ~VXLAN
+"
+
+ERROR_BRIDGE="BRIDGE: needed for network commands"
+ERROR_DUMMY="DUMMY: needed for network commands"
+ERROR_IP6_NF_NAT="IP6_NF_NAT: needed for network commands"
+ERROR_IP6_NF_TARGET_MASQUERADE="IP6_NF_TARGET_MASQUERADE: needed for network commands"
+ERROR_IPV6="IPV6: needed for network commands"
+ERROR_IP_NF_NAT="IP_NF_NAT: needed for network commands"
+ERROR_IP_NF_TARGET_MASQUERADE="IP_NF_TARGET_MASQUERADE: needed for network commands"
+ERROR_MACVLAN="MACVLAN: needed for network commands"
+ERROR_NETFILTER_XT_MATCH_COMMENT="NETFILTER_XT_MATCH_COMMENT: needed for network commands"
+ERROR_NET_IPGRE="NET_IPGRE: needed for network commands"
+ERROR_NET_IPGRE_DEMUX="NET_IPGRE_DEMUX: needed for network commands"
+ERROR_NET_IPIP="NET_IPIP: needed for network commands"
+ERROR_NF_NAT_MASQUERADE_IPV4="NF_NAT_MASQUERADE_IPV4: needed for network commands"
+ERROR_NF_NAT_MASQUERADE_IPV6="NF_NAT_MASQUERADE_IPV6: needed for network commands"
+ERROR_VXLAN="VXLAN: needed for network commands"
+
+EGO_PN="github.com/lxc/lxd"
+
+src_prepare() {
+ eapply_user
+ eapply "${FILESDIR}/de-translation-newline-1.patch"
+ eapply "${FILESDIR}/ptbr-translation-newline.patch"
+
+ cd "${S}/dist/dqlite" || die "Can't cd to dqlite dir"
+ eautoreconf
+}
+
+src_configure() {
+ export GOPATH="${S}/dist"
+ cd "${GOPATH}/sqlite" || die "Can't cd to sqlite dir"
+ econf --enable-replication --disable-amalgamation --disable-tcl --libdir="${EPREFIX}/usr/lib/lxd"
+
+ cd "${GOPATH}/dqlite" || die "Can't cd to dqlite dir"
+ PKG_CONFIG_PATH="${GOPATH}/sqlite/" econf --libdir=${EPREFIX}/usr/lib/lxd
+}
+
+src_compile() {
+ export GOPATH="${S}/dist"
+
+ cd "${GOPATH}/sqlite" || die "Can't cd to sqlite dir"
+ emake
+
+ cd "${GOPATH}/dqlite" || die "Can't cd to dqlite dir"
+ emake CFLAGS="-I${GOPATH}/sqlite" LDFLAGS="-L${GOPATH}/sqlite"
+
+ # We don't use the Makefile here because it builds targets with the
+ # assumption that `pwd` is in a deep gopath namespace, which we're not.
+ # It's simpler to manually call "go install" than patching the Makefile.
+ cd "${S}"
+ go install -v -x ${EGO_PN}/lxc || die "Failed to build the client"
+
+ if use daemon; then
+
+ # LXD depends on a patched, bundled sqlite with replication
+ # capabilities.
+ export CGO_CFLAGS="-I${GOPATH}/sqlite/ -I${GOPATH}/dqlite/include/"
+ export CGO_LDFLAGS="-L${GOPATH}/sqlite/.libs/ -L${GOPATH}/dqlite/.libs/ -Wl,-rpath,${EPREFIX}/usr/lib/lxd"
+ export LD_LIBRARY_PATH="${GOPATH}/sqlite/.libs/:${GOPATH}/dqlite/.libs/"
+
+ go install -v -x -tags libsqlite3 ${EGO_PN}/lxd || die "Failed to build the daemon"
+ fi
+
+ if use tools; then
+ go install -v -x ${EGO_PN}/fuidshift || die "Failed to build fuidshift"
+ go install -v -x ${EGO_PN}/lxc-to-lxd || die "Failed to build lxc-to-lxd"
+ go install -v -x ${EGO_PN}/lxd-benchmark || die "Failed to build lxd-benchmark"
+ go install -v -x ${EGO_PN}/lxd-p2c || die "Failed to build lxd-p2c"
+ fi
+
+ use nls && emake build-mo
+}
+
+src_test() {
+ if use daemon; then
+ export GOPATH="${S}/dist"
+ # This is mostly a copy/paste from the Makefile's "check" rule, but
+ # patching the Makefile to work in a non "fully-qualified" go namespace
+ # was more complicated than this modest copy/paste.
+ # Also: sorry, for now a network connection is needed to run tests.
+ # Will properly bundle test dependencies later.
+ go get -v -x github.com/rogpeppe/godeps
+ go get -v -x github.com/remyoudompheng/go-misc/deadcode
+ go get -v -x github.com/golang/lint/golint
+ go test -v ${EGO_PN}/lxd
+ else
+ einfo "No tests to run for client-only builds"
+ fi
+}
+
+src_install() {
+ local bindir="dist/bin"
+ dobin ${bindir}/lxc
+ if use daemon; then
+
+ export GOPATH="${S}/dist"
+ cd "${GOPATH}/sqlite" || die "Can't cd to sqlite dir"
+ emake DESTDIR="${D}" install
+
+ cd "${GOPATH}/dqlite" || die "Can't cd to dqlite dir"
+ emake DESTDIR="${D}" install
+
+ # Must only install libs
+ rm "${D}/usr/bin/sqlite3" || die "Can't remove custom sqlite3 binary"
+ rm -r "${D}/usr/include" || die "Can't remove include directory"
+
+ cd "${S}" || die "Can't cd to \${S}"
+ dosbin ${bindir}/lxd
+ fi
+
+ if use tools; then
+ dobin ${bindir}/fuidshift
+ dobin ${bindir}/lxc-to-lxd
+ dobin ${bindir}/lxd-benchmark
+ dobin ${bindir}/lxd-p2c
+ fi
+
+ if use nls; then
+ domo po/*.mo
+ fi
+
+ if use daemon; then
+ newinitd "${FILESDIR}"/${PN}.initd lxd
+ newconfd "${FILESDIR}"/${PN}.confd lxd
+
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+ fi
+
+ newbashcomp scripts/bash/lxd-client lxc
+
+ dodoc AUTHORS doc/*
+}
+
+pkg_postinst() {
+ elog
+ elog "Consult https://wiki.gentoo.org/wiki/LXD for more information,"
+ elog "including a Quick Start."
+
+ # The messaging below only applies to daemon installs
+ use daemon || return 0
+
+ # The control socket will be owned by (and writeable by) this group.
+ enewgroup lxd
+
+ # Ubuntu also defines an lxd user but it appears unused (the daemon
+ # must run as root)
+
+ elog
+ elog "Though not strictly required, some features are enabled at run-time"
+ elog "when the relevant helper programs are detected:"
+ elog "- sys-apps/apparmor"
+ elog "- sys-fs/btrfs-progs"
+ elog "- sys-fs/lvm2"
+ elog "- sys-fs/zfs"
+ elog "- sys-process/criu"
+ elog
+ elog "Since these features can't be disabled at build-time they are"
+ elog "not USE-conditional."
+ elog
+ elog "Be sure to add your local user to the lxd group."
+ elog
+ elog "Networks with bridge.mode=fan are unsupported due to requiring"
+ elog "a patched kernel and iproute2."
+}
+
+# TODO:
+# - man page, I don't see cobra generating it
+# - maybe implement LXD_CLUSTER_UPDATE per
+# https://discuss.linuxcontainers.org/t/lxd-3-5-has-been-released/2656
+# EM I'm not convinced it's a good design.