summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-05 22:24:06 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-05 22:24:22 +0000
commitacdbbba5090fa388f6d4914e10b65ba600c620b8 (patch)
treed3c732dcbd20b476f22b16c69d2781e3aaaad8b7 /app-emulation
parentxfce-extra/xfce4-notifyd: Bump to 0.3.3 (diff)
downloadgentoo-acdbbba5090fa388f6d4914e10b65ba600c620b8.tar.gz
gentoo-acdbbba5090fa388f6d4914e10b65ba600c620b8.tar.bz2
gentoo-acdbbba5090fa388f6d4914e10b65ba600c620b8.zip
app-emulation/dosemu: drop incomplete check for glibc
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild7
-rw-r--r--app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-no-glibc.patch18
2 files changed, 24 insertions, 1 deletions
diff --git a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
index d6693d283176..8a0011cbc409 100644
--- a/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
+++ b/app-emulation/dosemu/dosemu-1.4.1_pre20130107-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit eutils flag-o-matic pax-utils toolchain-funcs
+inherit autotools eutils flag-o-matic pax-utils toolchain-funcs
P_FD="dosemu-freedos-1.0-bin"
COMMIT="15cfb41ff20a052769d753c3262c57ecb050ad71"
@@ -46,6 +46,9 @@ S="${WORKDIR}/${PN}-code-${COMMIT}"
src_prepare() {
epatch "${FILESDIR}"/${P}-fortify.patch
epatch "${FILESDIR}"/${PN}-1.4.1_pre20091009-dash.patch
+ epatch "${FILESDIR}"/${P}-no-glibc.patch
+
+ epatch_user
# Has problems with -O3 on some systems
replace-flags -O[3-9] -O2
@@ -53,6 +56,8 @@ src_prepare() {
# This one is from media-sound/fluid-soundfont (bug #479534)
sed "s,/usr/share/soundfonts/default.sf2,${EPREFIX}/usr/share/sounds/sf2/FluidR3_GM.sf2,"\
-i src/plugin/fluidsynth/mid_o_flus.c || die
+
+ eautoreconf
}
src_configure() {
diff --git a/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-no-glibc.patch b/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-no-glibc.patch
new file mode 100644
index 000000000000..7c5b8a50a094
--- /dev/null
+++ b/app-emulation/dosemu/files/dosemu-1.4.1_pre20130107-no-glibc.patch
@@ -0,0 +1,18 @@
+The check has no AC_MGS_RESULT finish helper
+and gets called as
+ set ``
+on gcc-6 which clutters ./configure output.
+
+One of fallouts of https://bugs.gentoo.org/598798
+diff --git a/configure.ac b/configure.ac
+index 34a7f71..0f06f57 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -574,7 +574,2 @@ if test "$GCC" = "yes" ; then
+
+- AC_MSG_CHECKING(for glibc...)
+- set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__'|${CC-cc} -E -|awk '/XXAaZZ/ {print $2}'`
+- if test "$1" = "__GLIBC__"; then
+- AC_MSG_ERROR([Sorry, you need glibc.])
+- fi
+ fi