summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-10-15 18:41:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-10-15 18:43:52 -0500
commitad821b0778fdab76c62a630caf7d9f0cdcab6045 (patch)
tree2c2cddbe4c160e7bca81d32abdcef26f4d1b2ae0 /app-emulation
parentdev-libs/leatherman: 1.8.0 bump (diff)
downloadgentoo-ad821b0778fdab76c62a630caf7d9f0cdcab6045.tar.gz
gentoo-ad821b0778fdab76c62a630caf7d9f0cdcab6045.tar.bz2
gentoo-ad821b0778fdab76c62a630caf7d9f0cdcab6045.zip
app-emulation/diskimage-builder: 2.28.2 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.28.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 36b45c99d7e5..a3aca93a45ab 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-2.27.2.tar.gz 421433 BLAKE2B 089e68b07c6f79e54b8fb30e7a9328a6c55d1abb5f77b6592cc0b29b30a44a83803bdde93631e95e39d7fc82d9b5ff3fb425a7b94821b96f56421cbde9f8b078 SHA512 e2cc6f24d5bbfdf741d6b6e7e216d0e9631d6394cf3f3f4d34ce8a78ba2ba2ddbcb0b1434121f7ab1bd3600194777a5538651d9039c3bca06bb8cc621f06f037
DIST diskimage-builder-2.28.0.tar.gz 425808 BLAKE2B f3cceec35f019b248df8aaa94f70231dc51a9fed06cf93b16366536cfcf45b4477b7aa09371bb3cffe95f51c74d0abf9065285b7b74c5d805604c2b00df8f38f SHA512 6eddef513e8550fb6f90e917a504bac1166ef4355791bd9b0c10addebb8f84b783bf4e53dd472e6ed9acb5d3dcd951e675f4e9983ec4170c31afdb257b84e24d
+DIST diskimage-builder-2.28.2.tar.gz 424565 BLAKE2B 77bad24f857de7fb17cb727f7f5168f86434e4cfeecef286da5b3351e9fdfeb0d1dc2472f800024a35adb40aa04155bb7cfa3a0772ed8186a21b31b582809312 SHA512 0bdce552a896834c97f2a982865a93f39f62d0ee68d001c60d320e831c25456a392b4510ed94d7123851dad262e5ccb38a541d0dda5d620f91cf9ab54776efaa
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.28.2.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.28.2.ebuild
new file mode 100644
index 000000000000..86d3bb124b34
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.28.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"