summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-10-03 13:05:06 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-10-03 13:07:23 +0300
commitb1f355d4bd5f6dedb30a87324e5a5b23e72f0d29 (patch)
treec16954cde10734b7936d8866b27a4a15a8a9c20d /app-emulation
parentdev-python/python-evdev: specify header locations, EAPI 7 (diff)
downloadgentoo-b1f355d4bd5f6dedb30a87324e5a5b23e72f0d29.tar.gz
gentoo-b1f355d4bd5f6dedb30a87324e5a5b23e72f0d29.tar.bz2
gentoo-b1f355d4bd5f6dedb30a87324e5a5b23e72f0d29.zip
app-emulation/dynamips: revision bump
Bump EAPI to 6, add support for compilers other than GCC Drop old version Reported-by: Denis Pronin <dannftk@yandex.ru> Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Closes: https://bugs.gentoo.org/665562 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dynamips/Manifest1
-rw-r--r--app-emulation/dynamips/dynamips-0.2.12.ebuild47
-rw-r--r--app-emulation/dynamips/dynamips-0.2.14-r2.ebuild42
-rw-r--r--app-emulation/dynamips/files/0.2.14-docs.patch4
-rw-r--r--app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch11
5 files changed, 44 insertions, 61 deletions
diff --git a/app-emulation/dynamips/Manifest b/app-emulation/dynamips/Manifest
index 9f350ebfc4e6..3e4504e49624 100644
--- a/app-emulation/dynamips/Manifest
+++ b/app-emulation/dynamips/Manifest
@@ -1,2 +1 @@
-DIST dynamips-0.2.12-source.zip 995877 BLAKE2B 0bfc709f49b196763e8a3dcfde214e1e26c9c735257d588b72aefc3ca8dec2b1325ce3cb634b59555365c9dbd3819d959ab6e51e986c2dd62595b5566d76b39c SHA512 08f388027e3234a44a75de77f30d6c96f0d881c4db60435a237f6ae6e3804872fda422ab11249f5c7283054f7d2d8466886dcd6056e59fc90802e67fa7cb8c55
DIST dynamips-0.2.14-source.zip 961813 BLAKE2B 71da393bfd5624ad47eda578eafd0f5b8b535d9a93c3ebc8902901c0415168098bb27ea44e92cbb230d0cf2ebb904311665978f1b30e6d35c7792b813a5cd8d2 SHA512 8c3d85998a61cae1e3e82501a00e886c954686f9a19a44acb7dee8b13911c0155ce2cdfecbdc41ed5d279266abdf77a5c3f2753fde12217b138313ffa46dabf8
diff --git a/app-emulation/dynamips/dynamips-0.2.12.ebuild b/app-emulation/dynamips/dynamips-0.2.12.ebuild
deleted file mode 100644
index 134ef537bf0d..000000000000
--- a/app-emulation/dynamips/dynamips-0.2.12.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Cisco 7200/3600 Simulator"
-HOMEPAGE="http://www.gns3.net/dynamips/"
-SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-libs/elfutils
- net-libs/libpcap"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-makefile.patch"
-
- # enable verbose build
- sed -i \
- -e 's/@$(CC)/$(CC)/g' \
- stable/Makefile || die 'sed on stable/Makefile failed'
- # respect compiler
- tc-export CC
-
- epatch_user
-}
-
-src_compile() {
- if use amd64 || use x86; then
- emake DYNAMIPS_ARCH="${ARCH}"
- else
- emake DYNAMIS_ARCH="nojit"
- fi
-}
-
-src_install () {
- newbin dynamips.stable dynamips
- newbin nvram_export.stable nvram_export
- doman man/*
- dodoc README README.hypervisor TODO
-}
diff --git a/app-emulation/dynamips/dynamips-0.2.14-r2.ebuild b/app-emulation/dynamips/dynamips-0.2.14-r2.ebuild
new file mode 100644
index 000000000000..709519ab9275
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.14-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="http://www.gns3.net/dynamips/"
+SRC_URI="mirror://sourceforge/project/gns-3/Dynamips/${PV}/${P}-source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ipv6"
+
+RDEPEND="dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DOCS=( ChangeLog README RELEASE-NOTES )
+
+S="${WORKDIR}"
+
+PATCHES=( "${FILESDIR}/${PV}-docs.patch" )
+
+src_prepare() {
+ # comment out DYNAMIPS_FLAGS to respect CFLAGS
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DANY_COMPILER=1
+ -DENABLE_IPV6="$(usex ipv6)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/app-emulation/dynamips/files/0.2.14-docs.patch b/app-emulation/dynamips/files/0.2.14-docs.patch
index 1d744062e5b5..0572a04c4825 100644
--- a/app-emulation/dynamips/files/0.2.14-docs.patch
+++ b/app-emulation/dynamips/files/0.2.14-docs.patch
@@ -1,5 +1,5 @@
---- CMakeLists-orig.txt 2014-11-28 14:51:14.375913296 +0900
-+++ CMakeLists.txt 2014-11-28 14:52:09.579369288 +0900
+--- a/CMakeLists.txt 2014-11-28 14:51:14.375913296 +0900
++++ b/CMakeLists.txt 2014-11-28 14:52:09.579369288 +0900
@@ -37,16 +37,6 @@
add_subdirectory ( stable )
add_subdirectory ( unstable )
diff --git a/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch b/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch
deleted file mode 100644
index 431f2df8ac74..000000000000
--- a/app-emulation/dynamips/files/dynamips-0.2.12-makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- stable/origMakefile 2014-03-27 18:17:28.000000000 -0400
-+++ stable/Makefile 2014-05-30 18:07:28.164255039 -0400
-@@ -19,7 +19,7 @@
- PPC32_ARCH_INC_FILE=\"ppc32_$(DYNAMIPS_ARCH)_trans.h\"
- OSNAME=unknown
-
--CFLAGS+= $(INCLUDE) -Wall -O2 -fomit-frame-pointer \
-+CFLAGS+= $(INCLUDE) -Wall \
- -DJIT_ARCH=\"$(DYNAMIPS_ARCH)\" -DJIT_CPU=CPU_$(DYNAMIPS_ARCH) \
- -DMIPS64_ARCH_INC_FILE=$(MIPS64_ARCH_INC_FILE) \
- -DPPC32_ARCH_INC_FILE=$(PPC32_ARCH_INC_FILE) \