summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-11-05 01:11:02 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2017-11-05 01:53:04 -0400
commitb2297764d02e1b81d6d6e45af616558e31c69c3f (patch)
tree2885c6ee3321fb263ab626e787d3d01f9853821e /app-emulation
parentapp-emulation/wine-staging: Refactor to dynamically add patchbin dep (diff)
downloadgentoo-b2297764d02e1b81d6d6e45af616558e31c69c3f.tar.gz
gentoo-b2297764d02e1b81d6d6e45af616558e31c69c3f.tar.bz2
gentoo-b2297764d02e1b81d6d6e45af616558e31c69c3f.zip
app-emulation/wine-staging: add missing xfixes handling
Reported-By: Robert Walker <bob.mt.wya@gmail.com> Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-staging/wine-staging-2.10-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.11-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.12-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.13-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.14-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.15-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.16-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.17-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.18.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-2.9-r1.ebuild2
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild2
11 files changed, 22 insertions, 0 deletions
diff --git a/app-emulation/wine-staging/wine-staging-2.10-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.10-r1.ebuild
index f4d14b26fc45..b119a5cd8635 100644
--- a/app-emulation/wine-staging/wine-staging-2.10-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.10-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.11-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.11-r1.ebuild
index f4d14b26fc45..b119a5cd8635 100644
--- a/app-emulation/wine-staging/wine-staging-2.11-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.11-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.12-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.12-r1.ebuild
index f4d14b26fc45..b119a5cd8635 100644
--- a/app-emulation/wine-staging/wine-staging-2.12-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.12-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.13-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.13-r1.ebuild
index f4d14b26fc45..b119a5cd8635 100644
--- a/app-emulation/wine-staging/wine-staging-2.13-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.13-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.14-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.14-r1.ebuild
index a5b3fa57a038..9df84ca6f8f8 100644
--- a/app-emulation/wine-staging/wine-staging-2.14-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.14-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.15-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.15-r1.ebuild
index a5b3fa57a038..9df84ca6f8f8 100644
--- a/app-emulation/wine-staging/wine-staging-2.15-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.15-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.16-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.16-r1.ebuild
index a5b3fa57a038..9df84ca6f8f8 100644
--- a/app-emulation/wine-staging/wine-staging-2.16-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.16-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.17-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.17-r1.ebuild
index a5b3fa57a038..9df84ca6f8f8 100644
--- a/app-emulation/wine-staging/wine-staging-2.17-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.17-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.18.ebuild b/app-emulation/wine-staging/wine-staging-2.18.ebuild
index cacc432e2505..7fc52bbe654b 100644
--- a/app-emulation/wine-staging/wine-staging-2.18.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.18.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -456,6 +457,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-2.9-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.9-r1.ebuild
index f4d14b26fc45..b119a5cd8635 100644
--- a/app-emulation/wine-staging/wine-staging-2.9-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.9-r1.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -460,6 +461,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index cacc432e2505..7fc52bbe654b 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
x11-libs/libXrandr[${MULTILIB_USEDEP}]
x11-libs/libXi[${MULTILIB_USEDEP}]
x11-libs/libXxf86vm[${MULTILIB_USEDEP}]
@@ -456,6 +457,7 @@ multilib_src_configure() {
$(use_with udev)
$(use_with v4l)
$(use_with X x)
+ $(use_with X xfixes)
$(use_with xcomposite)
$(use_with xinerama)
$(use_with xml)