summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-30 19:20:36 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-30 19:20:36 -0800
commitbe1b9590db51c709dfd721ca9bfbc49efeee91e3 (patch)
treea09e06d43090a75f22c3af7912e5a7e2b19dc094 /app-emulation
parentsys-apps/ripgrep: 0.10.0-r1 stable on amd64 (diff)
downloadgentoo-be1b9590db51c709dfd721ca9bfbc49efeee91e3.tar.gz
gentoo-be1b9590db51c709dfd721ca9bfbc49efeee91e3.tar.bz2
gentoo-be1b9590db51c709dfd721ca9bfbc49efeee91e3.zip
app-emulation/vagrant: drop old
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vagrant/Manifest2
-rw-r--r--app-emulation/vagrant/files/vagrant.in61
-rw-r--r--app-emulation/vagrant/vagrant-2.1.1.ebuild79
-rw-r--r--app-emulation/vagrant/vagrant-2.1.2-r1.ebuild83
-rw-r--r--app-emulation/vagrant/vagrant-2.1.2.ebuild79
5 files changed, 0 insertions, 304 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index 03a22b8ca6d5..9b2e5b6e9d44 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,4 +1,2 @@
-DIST vagrant-2.1.1.tar.gz 1204711 BLAKE2B 88a6254091104eed702e07a4203a264b883869fb028b8d30fd51ddfc2053aec363683a2e73d1454ce92b705440920d5c80c0f967e4dc110bf425ce17973efccd SHA512 6cc82b4c33b196fce2bc460447afd152e53c3c17b45db5d80958ff631f6747c386b625ff26e3d8830a88b2feca82d550ad1de32e7c7607dffb25960af43092f5
-DIST vagrant-2.1.2.tar.gz 1218801 BLAKE2B 742f27ca6c28c9738c09ef61c742be07121b5a804fa401115520633e5840c62c8e879fae078c5532704f6f6f7d7a9081d48e3f7570cfe6e6dd84f8df244a34ae SHA512 d9a2612697842885d23d1a9a452ef9d8b03defa4e6f7a808725ac7c3a87300affcfdd89ee3a42334259601e19f1e56bfd86a5aa7b404eac26bc22dcfd4a57751
DIST vagrant-2.1.5.tar.gz 1238788 BLAKE2B 8e3dfeb4d830fde1984c08b16422c99b51ce455fcc63e1fad0eca7860efccbf2e77edc13537bfa495345e585b559fe5462ae872decce036b45c1f54c453983ea SHA512 544216eb25c06a1ebddbadcc9d2d6a6dd9932e33d2554e3d51dba0e24a339b9afe0b85d1322bdb67c5de3d070aa4c854f1ccc931b23ea80f0625eb4d1f120238
DIST vagrant-2.2.2.tar.gz 1223645 BLAKE2B 595d26a11f27a23a9e66386820dec7c23fbafe079e9e9750e7cbc928cac2e965782abbb062f6b04efd367b56297d040af2b4f4f56d6df06e604f018110e10329 SHA512 70c83fcd896ae3b84fac22c539eb85db9bf08c8f75108d5f2b86841821cf7a885b72565814519b6f2ef3422d84d2f67fc402b983b1a15c1edfd0dc78196cd957
diff --git a/app-emulation/vagrant/files/vagrant.in b/app-emulation/vagrant/files/vagrant.in
deleted file mode 100644
index 134cb31f299c..000000000000
--- a/app-emulation/vagrant/files/vagrant.in
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/usr/bin/env bash
-#
-# This is a wrapper to properly execute Vagrant within the embedded
-# Vagrant installation directory. This sets up proper environmental variables
-# so that everything loads and compiles to proper directories.
-
-for r in ruby24 ruby23 ruby22; do
- # not all ruby versions are guaranteed to be installed
- if ! command -v "${r}" >/dev/null 2>&1; then
- continue
- fi
-
- VAGRANT_DIR="$( "${r}" -e 'print Gem::default_path[-1] + "/gems/vagrant-@VAGRANT_VERSION@"' )"
-
- # Export the VAGRANT_EXECUTABLE so that pre-rubygems can optimize a bit
- export VAGRANT_EXECUTABLE="${VAGRANT_DIR}/bin/vagrant"
-
- if [ -f ${VAGRANT_EXECUTABLE} ] ;then
- ruby="${r}"
- break
- fi
-done
-
-if [ -z ${ruby} ]; then
- echo "Error: failed to find any usable ruby"
- exit 1
-fi
-
-# Export GEM_HOME based on VAGRANT_HOME
-#
-# This needs to be set because Bundler includes gem paths
-# from RubyGems' Gem.paths.
-if [ -z ${VAGRANT_HOME} ]; then
- VAGRANT_HOME="~/.vagrant.d"
-fi
-export GEM_HOME="${VAGRANT_HOME}/gems"
-
-# SSL certs
-export SSL_CERT_FILE="/etc/ssl/certs/ca-certificates.crt"
-
-# Export an environmental variable to say we're in a Vagrant
-# installer created environment.
-export VAGRANT_INSTALLER_ENV=1
-
-# This is currently used only in Vagrant::Plugin::Manager.system_plugins_file
-# to locate plugins configuration file.
-export VAGRANT_INSTALLER_EMBEDDED_DIR="/var/lib/vagrant"
-export VAGRANT_INSTALLER_VERSION=2
-
-# Export the OS as an environmental variable that Vagrant can access
-# so that it can behave better.
-export VAGRANT_DETECTED_OS="$(uname -s 2>/dev/null)"
-
-# Allow to install plugins even with deps in different slots (Bug #628648)
-export VAGRANT_DISABLE_STRICT_DEPENDENCY_ENFORCEMENT=1
-
-# Make it work with rvm (Bugs #474476 #628648)
-unset GEM_HOME GEM_PATH
-
-# Call the actual Vagrant bin with our arguments
-exec "${ruby}" "${VAGRANT_EXECUTABLE}" "$@"
diff --git a/app-emulation/vagrant/vagrant-2.1.1.ebuild b/app-emulation/vagrant/vagrant-2.1.1.ebuild
deleted file mode 100644
index ee48d642baae..000000000000
--- a/app-emulation/vagrant/vagrant-2.1.1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-USE_RUBY="ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+virtualbox"
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- app-arch/libarchive
- net-misc/curl
- virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.6.0
- >=dev-ruby/erubis-2.7.0
- <dev-ruby/i18n-0.8.0:*
- >=dev-ruby/listen-3.1.5
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
- >=dev-ruby/net-ssh-4.2.0:*
- >=dev-ruby/net-sftp-2.1
- >=dev-ruby/net-scp-1.2.0
- || ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
- >=dev-ruby/nokogiri-1.7.1
- <dev-ruby/mime-types-3:*
-"
-
-ruby_add_bdepend "
- >=dev-ruby/rake-12.0.0
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
- -e '/ruby_dep/s/<=/>=/' \
- -i ${PN}.gemspec || die
-
- # remove windows-specific gems
- sed -e '/wdm\|win32-\|winrm/d' \
- -i ${PN}.gemspec || die
-
- # remove bsd-specific gems
- sed -e '/rb-kqueue/d' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- newbashcomp contrib/bash/completion.sh ${PN}
- all_fakegem_install
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-}
diff --git a/app-emulation/vagrant/vagrant-2.1.2-r1.ebuild b/app-emulation/vagrant/vagrant-2.1.2-r1.ebuild
deleted file mode 100644
index 77b5794d5670..000000000000
--- a/app-emulation/vagrant/vagrant-2.1.2-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+virtualbox"
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- app-arch/libarchive
- net-misc/curl
- virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.6.0
- >=dev-ruby/erubis-2.7.0
- <dev-ruby/i18n-0.8.0:*
- >=dev-ruby/listen-3.1.5
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
- >=dev-ruby/net-ssh-4.2.0:*
- >=dev-ruby/net-sftp-2.1
- >=dev-ruby/net-scp-1.2.0
- || ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
- >=dev-ruby/nokogiri-1.7.1
- <dev-ruby/mime-types-3:*
-"
-
-# upstream specifies rake>=12 but it apparently doesn't need something this
-# recent. Because vagrant builds fine with rake 10 and because stabilizing rake
-# is tricky, we specify a lower dependency requirement here. This way, we'll be
-# able to stabilize vagrant sooner.
-ruby_add_bdepend "
- >=dev-ruby/rake-10.0.0
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
- -e '/ruby_dep/s/<=/>=/' \
- -i ${PN}.gemspec || die
-
- # remove windows-specific gems
- sed -e '/wdm\|win32-\|winrm/d' \
- -i ${PN}.gemspec || die
-
- # remove bsd-specific gems
- sed -e '/rb-kqueue/d' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}-r1.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- newbashcomp contrib/bash/completion.sh ${PN}
- all_fakegem_install
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-}
diff --git a/app-emulation/vagrant/vagrant-2.1.2.ebuild b/app-emulation/vagrant/vagrant-2.1.2.ebuild
deleted file mode 100644
index ee48d642baae..000000000000
--- a/app-emulation/vagrant/vagrant-2.1.2.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-USE_RUBY="ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
-RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="A tool for building and distributing development environments"
-HOMEPAGE="https://vagrantup.com/"
-SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+virtualbox"
-RESTRICT="test"
-
-RDEPEND="${RDEPEND}
- app-arch/libarchive
- net-misc/curl
- virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
-
-ruby_add_rdepend "
- >=dev-ruby/childprocess-0.6.0
- >=dev-ruby/erubis-2.7.0
- <dev-ruby/i18n-0.8.0:*
- >=dev-ruby/listen-3.1.5
- >=dev-ruby/hashicorp-checkpoint-0.1.5
- >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
- >=dev-ruby/net-ssh-4.2.0:*
- >=dev-ruby/net-sftp-2.1
- >=dev-ruby/net-scp-1.2.0
- || ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
- >=dev-ruby/nokogiri-1.7.1
- <dev-ruby/mime-types-3:*
-"
-
-ruby_add_bdepend "
- >=dev-ruby/rake-12.0.0
-"
-
-all_ruby_prepare() {
- # remove bundler support
- sed -i '/[Bb]undler/d' Rakefile || die
- rm Gemfile || die
-
- # loosen dependencies
- sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
- -e '/ruby_dep/s/<=/>=/' \
- -i ${PN}.gemspec || die
-
- # remove windows-specific gems
- sed -e '/wdm\|win32-\|winrm/d' \
- -i ${PN}.gemspec || die
-
- # remove bsd-specific gems
- sed -e '/rb-kqueue/d' \
- -i ${PN}.gemspec || die
-
- sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
-}
-
-all_ruby_install() {
- newbashcomp contrib/bash/completion.sh ${PN}
- all_fakegem_install
-
- # provide executable similar to upstream:
- # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
- dobin "${PN}"
-
- # directory for plugins.json
- keepdir /var/lib/vagrant
-}