summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-05 20:02:43 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-05 20:14:37 -0500
commitc6a29ec0aea3193dbbfba38c0fe65f28841c123e (patch)
treeb9e9dff9951b93e29f8c4f09ed484207dcddc989 /app-emulation
parentapp-emulation/wine-vanilla: drop 7.0-r3 (diff)
downloadgentoo-c6a29ec0aea3193dbbfba38c0fe65f28841c123e.tar.gz
gentoo-c6a29ec0aea3193dbbfba38c0fe65f28841c123e.tar.bz2
gentoo-c6a29ec0aea3193dbbfba38c0fe65f28841c123e.zip
app-emulation/wine-vanilla: filter lto and no-plt directly
These are semi-popular and no reason to allow something that fails to build even with USE=custom-cflags (that's more aimed at runtime fragility than build failures here). Could imagine -flto or maybe even -fno-plt being "potentially" whitelisted by strip-flags as it gain more support too. Note -fno-plt is only an issue with USE=-mingw. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild6
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild6
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild6
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.21-r1.ebuild6
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.22.ebuild6
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild6
6 files changed, 24 insertions, 12 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild
index c0992e01230c..e17d6a292d1b 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild
@@ -218,8 +218,10 @@ src_configure() {
$(usev !odbc ac_cv_lib_soname_odbc=)
)
- tc-ld-force-bfd #867097
- use custom-cflags || strip-flags # can break in obscure ways, also no lto
+ tc-ld-force-bfd # builds with non-bfd but broken at runtime (bug #867097)
+ filter-lto # build failure
+ use mingw || filter-flags -fno-plt # build failure
+ use custom-cflags || strip-flags # can break in obscure ways at runtime
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
index 69628d775f7e..5619b8ebd018 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
@@ -216,8 +216,10 @@ src_configure() {
$(usev !odbc ac_cv_lib_soname_odbc=)
)
- tc-ld-force-bfd #867097
- use custom-cflags || strip-flags # can break in obscure ways, also no lto
+ tc-ld-force-bfd # builds with non-bfd but broken at runtime (bug #867097)
+ filter-lto # build failure
+ use mingw || filter-flags -fno-plt # build failure
+ use custom-cflags || strip-flags # can break in obscure ways at runtime
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild
index e1d2da19d47b..883a0f427034 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild
@@ -216,8 +216,10 @@ src_configure() {
$(usev !odbc ac_cv_lib_soname_odbc=)
)
- tc-ld-force-bfd #867097
- use custom-cflags || strip-flags # can break in obscure ways, also no lto
+ tc-ld-force-bfd # builds with non-bfd but broken at runtime (bug #867097)
+ filter-lto # build failure
+ use mingw || filter-flags -fno-plt # build failure
+ use custom-cflags || strip-flags # can break in obscure ways at runtime
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.21-r1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.21-r1.ebuild
index 38fe963828ae..ed18a224f6b5 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.21-r1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.21-r1.ebuild
@@ -218,8 +218,10 @@ src_configure() {
$(usev !odbc ac_cv_lib_soname_odbc=)
)
- tc-ld-force-bfd #867097
- use custom-cflags || strip-flags # can break in obscure ways, also no lto
+ tc-ld-force-bfd # builds with non-bfd but broken at runtime (bug #867097)
+ filter-lto # build failure
+ use mingw || filter-flags -fno-plt # build failure
+ use custom-cflags || strip-flags # can break in obscure ways at runtime
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.22.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.22.ebuild
index b73eb356b435..02df0a4439ca 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.22.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.22.ebuild
@@ -213,8 +213,10 @@ src_configure() {
$(usev !odbc ac_cv_lib_soname_odbc=)
)
- tc-ld-force-bfd #867097
- use custom-cflags || strip-flags # can break in obscure ways, also no lto
+ tc-ld-force-bfd # builds with non-bfd but broken at runtime (bug #867097)
+ filter-lto # build failure
+ use mingw || filter-flags -fno-plt # build failure
+ use custom-cflags || strip-flags # can break in obscure ways at runtime
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index b73eb356b435..02df0a4439ca 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -213,8 +213,10 @@ src_configure() {
$(usev !odbc ac_cv_lib_soname_odbc=)
)
- tc-ld-force-bfd #867097
- use custom-cflags || strip-flags # can break in obscure ways, also no lto
+ tc-ld-force-bfd # builds with non-bfd but broken at runtime (bug #867097)
+ filter-lto # build failure
+ use mingw || filter-flags -fno-plt # build failure
+ use custom-cflags || strip-flags # can break in obscure ways at runtime
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold