summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-02-04 09:05:55 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-02-04 09:05:55 -0600
commitcdfb741d34233f5d2e57fe2f8cdd4946b0a3c8c5 (patch)
tree0bb52abc4f97d92a0ec6aadc101943b9e1caf84d /app-emulation
parentdev-python/reedsolomon: x86 stable wrt bug #768600 (diff)
downloadgentoo-cdfb741d34233f5d2e57fe2f8cdd4946b0a3c8c5.tar.gz
gentoo-cdfb741d34233f5d2e57fe2f8cdd4946b0a3c8c5.tar.bz2
gentoo-cdfb741d34233f5d2e57fe2f8cdd4946b0a3c8c5.zip
app-emulation/docker: 19.03.15 bump
Bug: https://bugs.gentoo.org/768612 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/docker/Manifest1
-rw-r--r--app-emulation/docker/docker-19.03.15.ebuild333
2 files changed, 334 insertions, 0 deletions
diff --git a/app-emulation/docker/Manifest b/app-emulation/docker/Manifest
index 66b41a5b1243..9d84879f4abe 100644
--- a/app-emulation/docker/Manifest
+++ b/app-emulation/docker/Manifest
@@ -1,3 +1,4 @@
DIST docker-19.03.13.tar.gz 18242693 BLAKE2B c19afed62694274298b42fc9af3b36c4cc6429b40f7e5447a996b87636a0d2e916476875652e20abd7aeab4e5e0e1cf887a04dcade1de03ded549fc36d911ac4 SHA512 5f34a14ef0b36a309d4a08926ac482ca82d24cdd873aa359c5ba7c65473cbb2e987fe615c38c1bc1c50135284da78a7eb98a8a0106d7d073aeda0cd8f1c31873
DIST docker-19.03.14.tar.gz 18278132 BLAKE2B 5e32cb482fdc40531aa4ba79dd447093859f568b3d8b5c3ed584c78d5709fabf2a1e05e82af2686cd87462e1abd899bd3f0a746f97937b7d16950f5e94264dff SHA512 5e48185a7787d5637fc11f43f6af604d56a5fa4367fd5a558bb3a5ef3c0d767f1c7f83ecef369453696b68eed81e49520453f267fbe8c2b840b3f62d35f25c28
+DIST docker-19.03.15.tar.gz 18284803 BLAKE2B a1fac5d841934382d12c781353546b7c7a8167d0f2dc4150659a4aece210ea7361c59de25e3d450dae20fd536ea8dc33a18e55f9565ee4fdc818166810391fbf SHA512 ffd8e683a93a6ce69789603d24457aebe3379594692cb3dadc25bc8d407771a29d76087b0ca70856707f151622b1853f283a1071311c033ff90a1e44b0d9ffbc
DIST docker-20.10.2.tar.gz 11045195 BLAKE2B 182ceabbabfa091eaae8ecf12a50dfbe296722072ee24cdde48c3ed2ad40f47d6f939830a00e1dbe7d5dfb1fa25ccda7efe25ce3e4f9a7bbf6ad85dac109168c SHA512 b514e98e3f71874fcf5374eeaaabc2c879691b48937dbc962be3577d834f571353d4f946aebfa69f1a62b1388c9220bfdff09b62bf62c134bd41f494e8506f56
diff --git a/app-emulation/docker/docker-19.03.15.ebuild b/app-emulation/docker/docker-19.03.15.ebuild
new file mode 100644
index 000000000000..7dc26e1596c7
--- /dev/null
+++ b/app-emulation/docker/docker-19.03.15.ebuild
@@ -0,0 +1,333 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/docker/docker-ce"
+
+if [[ ${PV} = *9999* ]]; then
+ # Docker cannot be fetched via "go get", thanks to autogenerated code
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}/src/${EGO_PN}"
+ inherit git-r3
+else
+ DOCKER_GITCOMMIT=420b1d3625
+ MY_PV=${PV/_/-}
+ SRC_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ [ "$DOCKER_GITCOMMIT" ] || die "DOCKER_GITCOMMIT must be added manually for each bump!"
+ inherit golang-vcs-snapshot
+fi
+inherit bash-completion-r1 golang-base linux-info systemd udev
+
+DESCRIPTION="The core functions you need to create Docker images and run Docker containers"
+HOMEPAGE="https://www.docker.com/"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor aufs btrfs +container-init device-mapper hardened overlay seccomp selinux"
+
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
+BDEPEND="
+ >=dev-lang/go-1.13.12
+ dev-go/go-md2man
+ virtual/pkgconfig
+"
+
+DEPEND="
+ acct-group/docker
+ >=dev-db/sqlite-3.7.9:3
+ apparmor? ( sys-libs/libapparmor )
+ btrfs? ( >=sys-fs/btrfs-progs-3.16.1 )
+ device-mapper? ( >=sys-fs/lvm2-2.02.89[thin] )
+ seccomp? ( >=sys-libs/libseccomp-2.2.1 )
+"
+
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#runtime-dependencies
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#optional-dependencies
+# https://github.com/docker/docker-ce/tree/master/components/engine/hack/dockerfile/install
+# make sure containerd, docker-proxy, runc and tini pinned to exact versions from ^,
+# for appropriate brachch/version of course
+RDEPEND="
+ ${DEPEND}
+ !sys-apps/systemd[-cgroup-hybrid(+)]
+ >=net-firewall/iptables-1.4
+ sys-process/procps
+ >=dev-vcs/git-1.7
+ >=app-arch/xz-utils-4.9
+ dev-libs/libltdl
+ ~app-emulation/containerd-1.3.9[apparmor?,btrfs?,device-mapper?,seccomp?,selinux?]
+ ~app-emulation/runc-1.0.0_rc10[apparmor?,seccomp?,selinux(-)?]
+ ~app-emulation/docker-proxy-0.8.0_p20201105
+ container-init? ( >=sys-process/tini-0.18.0[static] )
+"
+
+RESTRICT="installsources strip"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+# see "contrib/check-config.sh" from upstream's sources
+CONFIG_CHECK="
+ ~NAMESPACES ~NET_NS ~PID_NS ~IPC_NS ~UTS_NS
+ ~CGROUPS ~CGROUP_CPUACCT ~CGROUP_DEVICE ~CGROUP_FREEZER ~CGROUP_SCHED ~CPUSETS ~MEMCG
+ ~KEYS
+ ~VETH ~BRIDGE ~BRIDGE_NETFILTER
+ ~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE
+ ~NETFILTER_NETLINK ~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK ~NETFILTER_XT_MATCH_IPVS
+ ~IP_NF_NAT ~NF_NAT
+ ~POSIX_MQUEUE
+
+ ~USER_NS
+ ~SECCOMP
+ ~CGROUP_PIDS
+ ~MEMCG_SWAP
+
+ ~BLK_CGROUP ~BLK_DEV_THROTTLING
+ ~CGROUP_PERF
+ ~CGROUP_HUGETLB
+ ~NET_CLS_CGROUP
+ ~CFS_BANDWIDTH ~FAIR_GROUP_SCHED ~RT_GROUP_SCHED
+ ~IP_VS ~IP_VS_PROTO_TCP ~IP_VS_PROTO_UDP ~IP_VS_NFCT ~IP_VS_RR
+
+ ~VXLAN
+ ~CRYPTO ~CRYPTO_AEAD ~CRYPTO_GCM ~CRYPTO_SEQIV ~CRYPTO_GHASH ~XFRM_ALGO ~XFRM_USER
+ ~IPVLAN
+ ~MACVLAN ~DUMMY
+
+ ~OVERLAY_FS ~!OVERLAY_FS_REDIRECT_DIR
+ ~EXT4_FS_SECURITY
+ ~EXT4_FS_POSIX_ACL
+"
+
+ERROR_KEYS="CONFIG_KEYS: is mandatory"
+ERROR_MEMCG_SWAP="CONFIG_MEMCG_SWAP: is required if you wish to limit swap usage of containers"
+ERROR_RESOURCE_COUNTERS="CONFIG_RESOURCE_COUNTERS: is optional for container statistics gathering"
+
+ERROR_BLK_CGROUP="CONFIG_BLK_CGROUP: is optional for container statistics gathering"
+ERROR_IOSCHED_CFQ="CONFIG_IOSCHED_CFQ: is optional for container statistics gathering"
+ERROR_CGROUP_PERF="CONFIG_CGROUP_PERF: is optional for container statistics gathering"
+ERROR_CFS_BANDWIDTH="CONFIG_CFS_BANDWIDTH: is optional for container statistics gathering"
+ERROR_XFRM_ALGO="CONFIG_XFRM_ALGO: is optional for secure networks"
+ERROR_XFRM_USER="CONFIG_XFRM_USER: is optional for secure networks"
+
+pkg_setup() {
+ if kernel_is lt 3 10; then
+ ewarn ""
+ ewarn "Using Docker with kernels older than 3.10 is unstable and unsupported."
+ ewarn " - http://docs.docker.com/engine/installation/binaries/#check-kernel-dependencies"
+ fi
+
+ if kernel_is le 3 18; then
+ CONFIG_CHECK+="
+ ~RESOURCE_COUNTERS
+ "
+ fi
+
+ if kernel_is le 3 13; then
+ CONFIG_CHECK+="
+ ~NETPRIO_CGROUP
+ "
+ else
+ CONFIG_CHECK+="
+ ~CGROUP_NET_PRIO
+ "
+ fi
+
+ if kernel_is lt 4 5; then
+ CONFIG_CHECK+="
+ ~MEMCG_KMEM
+ "
+ ERROR_MEMCG_KMEM="CONFIG_MEMCG_KMEM: is optional"
+ fi
+
+ if kernel_is lt 4 7; then
+ CONFIG_CHECK+="
+ ~DEVPTS_MULTIPLE_INSTANCES
+ "
+ fi
+
+ if kernel_is lt 5 1; then
+ CONFIG_CHECK+="
+ ~NF_NAT_IPV4
+ ~IOSCHED_CFQ
+ ~CFQ_GROUP_IOSCHED
+ "
+ fi
+
+ if kernel_is lt 5 2; then
+ CONFIG_CHECK+="
+ ~NF_NAT_NEEDED
+ "
+ fi
+
+ if kernel_is lt 5 8; then
+ CONFIG_CHECK+="
+ ~MEMCG_SWAP_ENABLED
+ "
+ fi
+
+ if use aufs; then
+ CONFIG_CHECK+="
+ ~AUFS_FS
+ ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
+ "
+ ERROR_AUFS_FS="CONFIG_AUFS_FS: is required to be set if and only if aufs is patched to kernel instead of using standalone"
+ fi
+
+ if use btrfs; then
+ CONFIG_CHECK+="
+ ~BTRFS_FS
+ ~BTRFS_FS_POSIX_ACL
+ "
+ fi
+
+ if use device-mapper; then
+ CONFIG_CHECK+="
+ ~BLK_DEV_DM ~DM_THIN_PROVISIONING ~EXT4_FS ~EXT4_FS_POSIX_ACL ~EXT4_FS_SECURITY
+ "
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_compile() {
+ export GOPATH="${WORKDIR}/${P}"
+
+ # setup CFLAGS and LDFLAGS for separate build target
+ # see https://github.com/tianon/docker-overlay/pull/10
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="-L${ROOT}/usr/$(get_libdir)"
+
+ # if we're building from a tarball, we need the GITCOMMIT value
+ [[ ${DOCKER_GITCOMMIT} ]] && export DOCKER_GITCOMMIT
+
+ # fake golang layout
+ ln -s docker-ce/components/engine ../docker || die
+ ln -s docker-ce/components/cli ../cli || die
+
+ # let's set up some optional features :)
+ export DOCKER_BUILDTAGS=''
+ for gd in aufs btrfs device-mapper overlay; do
+ if ! use $gd; then
+ DOCKER_BUILDTAGS+=" exclude_graphdriver_${gd//-/}"
+ fi
+ done
+
+ for tag in apparmor seccomp selinux; do
+ if use $tag; then
+ DOCKER_BUILDTAGS+=" $tag"
+ fi
+ done
+
+ pushd components/engine || die
+
+ if use hardened; then
+ sed -i "s/EXTLDFLAGS_STATIC='/&-fno-PIC /" hack/make.sh || die
+ grep -q -- '-fno-PIC' hack/make.sh || die 'hardened sed failed'
+ sed "s/LDFLAGS_STATIC_DOCKER='/&-extldflags -fno-PIC /" \
+ -i hack/make/dynbinary-daemon || die
+ grep -q -- '-fno-PIC' hack/make/dynbinary-daemon || die 'hardened sed failed'
+ fi
+
+ # build daemon
+ VERSION="$(cat ../../VERSION)" \
+ ./hack/make.sh dynbinary || die 'dynbinary failed'
+
+ popd || die # components/engine
+
+ pushd components/cli || die
+
+ # build cli
+ DISABLE_WARN_OUTSIDE_CONTAINER=1 emake \
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')" \
+ VERSION="$(cat ../../VERSION)" \
+ GITCOMMIT="${DOCKER_GITCOMMIT}" \
+ dynbinary
+
+ # build man pages
+ go build -o gen-manpages github.com/docker/cli/man || die
+ ./gen-manpages --root . --target ./man/man1 || die
+ ./man/md2man-all.sh -q || die
+ rm gen-manpages || die
+ # see "components/cli/scripts/docs/generate-man.sh" (which also does "go get" for go-md2man)
+
+ popd || die # components/cli
+}
+
+src_install() {
+ dosym containerd /usr/bin/docker-containerd
+ dosym containerd-shim /usr/bin/docker-containerd-shim
+ dosym runc /usr/bin/docker-runc
+ use container-init && dosym tini /usr/bin/docker-init
+
+ pushd components/engine || die
+ newbin bundles/dynbinary-daemon/dockerd-${PV} dockerd
+
+ newinitd contrib/init/openrc/docker.initd docker
+ newconfd contrib/init/openrc/docker.confd docker
+
+ systemd_dounit contrib/init/systemd/docker.{service,socket}
+
+ udev_dorules contrib/udev/*.rules
+
+ dodoc AUTHORS CONTRIBUTING.md CHANGELOG.md NOTICE README.md
+ dodoc -r docs/*
+
+ insinto /usr/share/vim/vimfiles
+ doins -r contrib/syntax/vim/ftdetect
+ doins -r contrib/syntax/vim/syntax
+
+ # note: intentionally not using "doins" so that we preserve +x bits
+ dodir /usr/share/${PN}/contrib
+ cp -R contrib/* "${ED}/usr/share/${PN}/contrib"
+ popd || die # components/engine
+
+ pushd components/cli || die
+
+ newbin build/docker-* docker
+
+ doman man/man*/*
+
+ sed -i 's@dockerd\?\.exe@@g' contrib/completion/bash/docker || die
+ dobashcomp contrib/completion/bash/*
+ bashcomp_alias docker dockerd
+ insinto /usr/share/fish/vendor_completions.d/
+ doins contrib/completion/fish/docker.fish
+ insinto /usr/share/zsh/site-functions
+ doins contrib/completion/zsh/_*
+ popd || die # components/cli
+}
+
+pkg_postinst() {
+ udev_reload
+
+ elog
+ elog "To use Docker, the Docker daemon must be running as root. To automatically"
+ elog "start the Docker daemon at boot:"
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog " systemctl enable docker.service"
+ else
+ elog " rc-update add docker default"
+ fi
+ elog
+ elog "To use Docker as a non-root user, add yourself to the 'docker' group:"
+ elog ' usermod -aG docker <youruser>'
+ elog
+
+ if use device-mapper; then
+ elog " Devicemapper storage driver has been deprecated"
+ elog " It will be removed in a future release"
+ elog
+ fi
+
+ if use overlay; then
+ elog " Overlay storage driver/USEflag has been deprecated"
+ elog " in favor of overlay2 (enabled unconditionally)"
+ elog
+ fi
+
+ if has_version sys-fs/zfs; then
+ elog " ZFS storage driver is available"
+ elog " Check https://docs.docker.com/storage/storagedriver/zfs-driver for more info"
+ elog
+ fi
+}