summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-04 21:22:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-04 21:22:42 -0500
commitd6a6cfd6bf2734d53d3dc3f644258e5e9d90627b (patch)
tree5bcb4318719e7af9037626d98d6aaed803546e42 /app-emulation
parentsys-auth/keystone: 14.1.0 bump (diff)
downloadgentoo-d6a6cfd6bf2734d53d3dc3f644258e5e9d90627b.tar.gz
gentoo-d6a6cfd6bf2734d53d3dc3f644258e5e9d90627b.tar.bz2
gentoo-d6a6cfd6bf2734d53d3dc3f644258e5e9d90627b.zip
app-emulation/diskimage-builder: 2.21.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.21.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index f699aa26fb71..a1977ce249e9 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1 +1,2 @@
DIST diskimage-builder-2.20.3.tar.gz 403533 BLAKE2B 08aba837288123081d53b9f79af55c520acf5120dc7126781764c85aa633884ca812b46cd000f619f36138df34252652ea427dbd73aa215196883046b0baa469 SHA512 efefd3c19643e75794293519286d1df81b8bf88511d394b13addfd8953368f3ff6cd57a884b77a161d0b7d01b97624e4dd91d79497e22058f24747ee4a24df3a
+DIST diskimage-builder-2.21.0.tar.gz 409367 BLAKE2B 25c8a819be8674eee38a97e822151527dd77d3f5e85016ebc1a7fa5bf907f64bdac47012eb748b69273b519580c6ea4ca845abd7800ddb4e3f60dd81da546a73 SHA512 51a871a772fd4ae35d0a8ea51f7c01502c374805f5de5ab37c2f18ea868a829c7085ecaa6a62690e8d6e85afe225cbab7ed86266eb5fc3e8741a8ff968cb35f9
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.21.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.21.0.ebuild
new file mode 100644
index 000000000000..4c5588077dbd
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.21.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"