summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-02-07 19:28:54 -0800
committerZac Medico <zmedico@gentoo.org>2020-02-07 19:29:35 -0800
commitd7f328dcb1dbf27213e583529044446bd02ef3ca (patch)
tree21b2dfa92b74d378ba6950547f11120387d33020 /app-emulation
parentnet-p2p/cpuminer-opt: Cleanup old versions (diff)
downloadgentoo-d7f328dcb1dbf27213e583529044446bd02ef3ca.tar.gz
gentoo-d7f328dcb1dbf27213e583529044446bd02ef3ca.tar.bz2
gentoo-d7f328dcb1dbf27213e583529044446bd02ef3ca.zip
app-emulation/buildah: Bump to version 1.14.0
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/buildah/Manifest1
-rw-r--r--app-emulation/buildah/buildah-1.14.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emulation/buildah/Manifest b/app-emulation/buildah/Manifest
index b28f477fd51b..e9b62a1614ad 100644
--- a/app-emulation/buildah/Manifest
+++ b/app-emulation/buildah/Manifest
@@ -2,4 +2,5 @@ DIST buildah-1.11.5.tar.gz 10594213 BLAKE2B 421d4ea78ad84fbae42086b8d49fec26db8e
DIST buildah-1.11.6.tar.gz 10600477 BLAKE2B b70849ca0121e32cd66da3da282a443688c15a783a1be7d5d3650bf1122c865e9674d0790fb599f6da4c04072a19360aa224ccc76d516e8a8e71061c903dd0e1 SHA512 419d51d0b430dbc38862bad218cf0bb9a698472dd3932e69fa6bcfb2023b9cd10cf03916f2333892cdcc051ce799664619c62941965a59420d81ba4706e9d7be
DIST buildah-1.12.0.tar.gz 10717080 BLAKE2B 67107684d625ef23166d666dba50244861e6903f46315d8bae4d313d3585da154b7ee5f87ae8ab69ca717fdf68b914dee0cbcf2e1e95c34ebfccee4739db1d62 SHA512 ed7d77dfe88f613ef4f756455d889d707707ad16f8f6a9b514a8fbaabb56fef58db54ceb2344954a9311bcc6f1f000b21ac461f9b612b8534ae6a4594ad7a16d
DIST buildah-1.13.1.tar.gz 10928426 BLAKE2B 7f790e2e6499543f6ddae5582f03e4e8a2429783512bf53ffa48d010b1338c4e232117e8b175057205c75ee839981564358239d08d48dbdef8cae80bbacc6554 SHA512 89c02f3c485408f16d6334bb4621accbb7de5f8d3d4458eb4c925468da1f6c14a18132e8f643e965d3054f05a90ada3c4911e539541f9ca045ca606c9ce1bed9
+DIST buildah-1.14.0.tar.gz 10895764 BLAKE2B afc99c12737651997785ce96793afbff24e514a89e445ec5e176940940335b5966cf6e05e3d418d2aad2308d604e05879874eb5d5c07182dc0484e43411628e7 SHA512 c2fe27ccff81cc22dcb398f6d57f618015a1f534510888966483002d552c5f233b8899f639dac15d0f299c6c618e6f1d9889e65c745ce4709e7abd9498258a86
DIST containers-storage-1.14.0-vfs-user-xattrs.patch 14835 BLAKE2B 99c35933dcb25385ee83b80cf282c11c738d0e4d91216cc08a50522f6caa9bca5938299412908f16df404f99e80616a10b4c02c0ebc38240a987830ddaf15008 SHA512 62c7ed49728bd12b5706f59b0d4af3b18d90e8cfc2b06e681f84fe3f5d3e0cd5c0317147109c4e3ec4fec26f82c269af3c9813e47339ce102e4e97400b74627d
diff --git a/app-emulation/buildah/buildah-1.14.0.ebuild b/app-emulation/buildah/buildah-1.14.0.ebuild
new file mode 100644
index 000000000000..eb7c61b39ef6
--- /dev/null
+++ b/app-emulation/buildah/buildah-1.14.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 go-module
+
+KEYWORDS="~amd64"
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="selinux"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="5965d9a"
+SRC_URI="https://github.com/containers/buildah/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+RDEPEND="app-crypt/gpgme:=
+ app-emulation/skopeo
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-fs/lvm2:=
+ sys-libs/libseccomp:=
+ selinux? ( sys-libs/libselinux:= )"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -e 's|^\(GIT_COMMIT ?= \).*|\1'${GIT_COMMIT}'|' -i Makefile || die
+
+ [[ -f selinux_tag.sh ]] || die
+ use selinux || { echo -e "#!/bin/sh\ntrue" > \
+ selinux_tag.sh || die; }
+}
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME
+ emake all
+}
+
+src_install() {
+ dodoc CHANGELOG.md CONTRIBUTING.md README.md install.md troubleshooting.md
+ doman docs/*.1
+ dodoc -r docs/tutorials
+ dobin ${PN} imgtype
+ dobashcomp contrib/completions/bash/buildah
+}
+
+src_test() {
+ emake test-unit
+}