summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2019-09-06 16:37:57 -0700
committerZac Medico <zmedico@gentoo.org>2019-09-06 16:42:59 -0700
commitdaa82b31d06f22e506687af38d5f2f46a4fc5a47 (patch)
treee4222c134c9f97a2b9cb6adbb02e5fd9c9edee7f /app-emulation
parentapp-emulation/skopeo: Fix compile with go-1.13 (diff)
downloadgentoo-daa82b31d06f22e506687af38d5f2f46a4fc5a47.tar.gz
gentoo-daa82b31d06f22e506687af38d5f2f46a4fc5a47.tar.bz2
gentoo-daa82b31d06f22e506687af38d5f2f46a4fc5a47.zip
app-emulation/reg: Fix compile with go-1.13
Use GO111MODULE=on together with -mod=vendor since otherwise -mod=vendor fails with go-1.12 like this: build flag -mod=vendor only valid when using modules Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/reg/reg-0.16.0_p20190102.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-emulation/reg/reg-0.16.0_p20190102.ebuild b/app-emulation/reg/reg-0.16.0_p20190102.ebuild
index 3d7a774209c3..e1be9fc0449f 100644
--- a/app-emulation/reg/reg-0.16.0_p20190102.ebuild
+++ b/app-emulation/reg/reg-0.16.0_p20190102.ebuild
@@ -36,7 +36,7 @@ src_prepare() {
src_compile() {
pushd src/${EGO_PN} || die
- GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+ GOPATH="${S}" GO111MODULE=on go build -mod=vendor -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
popd || die
}