summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-02-26 15:23:58 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-02-26 15:24:16 -0600
commitdbc12eca2a307d8c5a36133d39f1f87bf27b5c11 (patch)
tree3c9f3574ff4444d5feb84657043e171edbcfd458 /app-emulation
parentsys-cluster/swift: 2.17.1 and 2.19.1 bump (diff)
downloadgentoo-dbc12eca2a307d8c5a36133d39f1f87bf27b5c11.tar.gz
gentoo-dbc12eca2a307d8c5a36133d39f1f87bf27b5c11.tar.bz2
gentoo-dbc12eca2a307d8c5a36133d39f1f87bf27b5c11.zip
app-emulation/diskimage-builder: 2.20.2 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.20.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 1ec0333cdb4e..8574b6ba6da7 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,3 +1,4 @@
DIST diskimage-builder-2.19.0.tar.gz 359520 BLAKE2B 2ddbee82cc45267faa45e7fa8b80012096676ca792eed6aee766d24fd3a5297f7f21af94c84259308fd0a48b9c913ba94575333d792b7dcd67c09d6493ff3f2b SHA512 57da6f0507a96f873bc034862dd58649d8d9ff65c7ad83f8245658fed5919b47ac29c5f8d1bb9ff2d544304955c48fa1ff3a183d90ba47bcc8d1f88c09e4014c
DIST diskimage-builder-2.20.0.tar.gz 366139 BLAKE2B 51399a4dad2dfb9100e4d196bae0cbe21d67a603ae8a3c5fb445de30cae7216d68090a8a4cdcd7839b9a11b472f5933d5d09814e60ad3ed1df3c373d012be97f SHA512 0d7e725eed0af0c549705029cf9af465d1ea10fa5ec82d6848a437d51783f8749ed613231fd4218db65f41b560eed16db5254788a097398ac267edf2ef04cea5
DIST diskimage-builder-2.20.1.tar.gz 361740 BLAKE2B 7e334694b2a103f9c742da6f174e40456b8d190648c32209f333a030498b2347e7dfe0f96e2143f87d9573dabc68f1acabfbc292e5796b017128f5bb1368dd5b SHA512 09567f0c6f4de44330168c52af52070e348c1e2c53e9cd2140679f97c4da8c175f2627c7851e33c8ca9133065cd65fe0f2f8256ea7a6638cad2a9c87c5219fdc
+DIST diskimage-builder-2.20.2.tar.gz 361048 BLAKE2B 75a75b895b57a038bcea7b5a9a4936abd9cf99e4c351e72856e61ea7a2b95f5e62cfd43d11443919957fc844967e5e510ea3258bcaee6266481d6efe45c41664 SHA512 b16716217f8977be1787c74df213853adaecd384120438c31bd18cb603d8ca6bf7430bd54826c7c3b63488ce366aa3cba5c0e7b166fa245f740093abecc99fc9
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.20.2.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.20.2.ebuild
new file mode 100644
index 000000000000..4c5588077dbd
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.20.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"