summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-15 16:19:13 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-15 16:19:13 +0200
commite4f0dc241a1d5be090fcaf488f522bbc7bf79a57 (patch)
treeb748ee8acf8a9e4a9bcaeca9dc61748067f608d2 /app-emulation
parentapp-emulation/qemu: fix major TCG crash (diff)
downloadgentoo-e4f0dc241a1d5be090fcaf488f522bbc7bf79a57.tar.gz
gentoo-e4f0dc241a1d5be090fcaf488f522bbc7bf79a57.tar.bz2
gentoo-e4f0dc241a1d5be090fcaf488f522bbc7bf79a57.zip
app-emulation/reg: Version bump to 0.13.4
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/reg/Manifest1
-rw-r--r--app-emulation/reg/reg-0.13.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/reg/Manifest b/app-emulation/reg/Manifest
index f2a9c31b3d0f..a7d6531b1903 100644
--- a/app-emulation/reg/Manifest
+++ b/app-emulation/reg/Manifest
@@ -1,2 +1,3 @@
DIST reg-0.13.1.tar.gz 2931156 BLAKE2B 56245364c348f800e77b25d4c7326a721bd041ac865aa4ac55eefa60a6d1746176e109247967f42bc48727c56fd91c47f2d76aa245f208aff64a26b77b4394f8 SHA512 c64b5a21cb5f2e3d64d9a80309a2eab3e1002b6aba1a59b87d873326e9c2c722ccbfa0778aa14a2cc1fca86dcd3ad1bf7eeef3e7293c835fef00e11e413decfb
DIST reg-0.13.3.tar.gz 5396000 BLAKE2B c5fa658010cb5c1cc21d7edfc1b18fac8c65cf2bd3c6de213ab238aabcb1377096172b5484a92f18a04f9ef4c01124dcfcfd4e6eabaf9f9a9b272c6f1f1fc482 SHA512 aefe0e5d3b1a02d54e67a4c7892e6b6c7581793f9e45995933200125c275e38701ad25b772c4541714f72ad1b43865e484bd062e40edbb7ed5faf2a572c224a1
+DIST reg-0.13.4.tar.gz 5401627 BLAKE2B 278462ff66917833feb9a660b39f9826afe1b71f7a75dad07f3673bd5ba63496152aa70147649ddf9d2266cbad3903ba3a4bbe4a7def76a932ea45131bdda8c5 SHA512 f8a1a52824b64cc252a5cd4f6c18d8cf73c88170342f0bab61664f5cdb50295510182c3c15afdfa02c1eae8d299e347a78b47d171ca275c01ecfd9228323c872
diff --git a/app-emulation/reg/reg-0.13.4.ebuild b/app-emulation/reg/reg-0.13.4.ebuild
new file mode 100644
index 000000000000..f22026d1213f
--- /dev/null
+++ b/app-emulation/reg/reg-0.13.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/reg"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="8dba69bce413988846a6defa063f35ab38a31991"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Docker registry v2 command line client"
+HOMEPAGE="https://github.com/genuinetools/reg"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc src/${EGO_PN}/README.md
+}