summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-25 16:04:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-25 16:04:35 -0500
commite90767c9ddb79ea1945a649959635e0a9187b93e (patch)
treebde15d58e0290047fb4ae508b38e43ffe3acc701 /app-emulation
parentmedia-gfx/cura: works with py38 (diff)
downloadgentoo-e90767c9ddb79ea1945a649959635e0a9187b93e.tar.gz
gentoo-e90767c9ddb79ea1945a649959635e0a9187b93e.tar.bz2
gentoo-e90767c9ddb79ea1945a649959635e0a9187b93e.zip
app-emulation/diskimage-builder: 2.37.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/diskimage-builder/Manifest1
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index 01f11048c29c..729f7c974f51 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,2 +1,3 @@
DIST diskimage-builder-2.35.0.tar.gz 439947 BLAKE2B 9b148948caef031f44992aaa2b0463b6cc9390b0591fdfe6e82d8258becda61eb5aa0d87ae91ed73523057ae357dcf327d7ca9d8d6a1b66da7f2d535d6c32dc1 SHA512 c5ad15c7a793a6c4b17e09fb119ad1444273f930741ae68491ce3a95f416cf8bb76ed0f6df4e34e03359355426c9189f2f5a8b730cb9ffd027a0bbd676f62310
DIST diskimage-builder-2.36.0.tar.gz 441509 BLAKE2B 4f8ec1686df8438c53eb088e52b954d0b84c8f327108599970f987db8de0f5ea7491e123c5f41fa9ff058d8f9d30238a533357b01e1cb671dd1fb3eb96ad28cb SHA512 f3fc13195742b25b8cca72d8b5630900d77f5af69dd9d153c44875e9e8f8f27393a8478a4adcdc05ea9d5b73b742e066edb5ab636bfd8d88c404c8f0fe33f1e7
+DIST diskimage-builder-2.37.0.tar.gz 444651 BLAKE2B 4794af305949268888262737e0b7e353f54fdba7a95e067397fa3693fbd4c7574df99336b47946db18af5e437383017d448b655654fe1533a34eecee5b9c2b31 SHA512 7c8ce86c90f5414b8b64a740b332ea95b75288d66639b31a575b2cd31e4ffdf75225416712782fc82723643ead6558a557b07044c19774501de96ab6763ae88d
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild
new file mode 100644
index 000000000000..720474e33c48
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.37.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"