summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-12-11 00:20:01 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-12-11 00:20:01 +0100
commiteb9d3bde3033cafe5ae35dfec16a55fd938a77e8 (patch)
tree6931c73743ea0cb9a4d7b7da5077fa91ad3a5e91 /app-emulation
parentRevert "app-emulation/cadvisor: remove unused file" (diff)
downloadgentoo-eb9d3bde3033cafe5ae35dfec16a55fd938a77e8.tar.gz
gentoo-eb9d3bde3033cafe5ae35dfec16a55fd938a77e8.tar.bz2
gentoo-eb9d3bde3033cafe5ae35dfec16a55fd938a77e8.zip
app-emulation/cadvisor: Version bump to 0.28.3
Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cadvisor/Manifest1
-rw-r--r--app-emulation/cadvisor/cadvisor-0.28.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-emulation/cadvisor/Manifest b/app-emulation/cadvisor/Manifest
index 3464eac2165f..21e686d5dd1f 100644
--- a/app-emulation/cadvisor/Manifest
+++ b/app-emulation/cadvisor/Manifest
@@ -1 +1,2 @@
DIST cadvisor-0.28.2.tar.gz 4109967 BLAKE2B c55268a0768adeea75ecc2baa1093d5d5360d1e0be56cea467fe759278c7047060c4b78179a3a35801afbcf6415ffbeb7e0649c92e79878e5615c73a37eeabeb SHA512 e682b8e062ba373e5726a8076d5be75322e7c592bd751aa32da9a99e5d380a77fc4b376aa478b0beff18bae2bc8432d3a70542605681410d5e1e0b1919a6c252
+DIST cadvisor-0.28.3.tar.gz 4110487 BLAKE2B d6b9d6de67e5672a3ba57ea0c28f38e2e96ec43910f8f5bbbe17b377ccbadf026d4418928234149e9ad3936f4c0871d7c371dda2bea49111735a33520154b2d3 SHA512 da111d74bfa3485c42a03a027ccbf833886e561f3244a081ad5439f7a714767cf4666c43c17b0b976089ea40916089aaa2c6070ec4aefc19798a1d5325e005e4
diff --git a/app-emulation/cadvisor/cadvisor-0.28.3.ebuild b/app-emulation/cadvisor/cadvisor-0.28.3.ebuild
new file mode 100644
index 000000000000..c3666053995e
--- /dev/null
+++ b/app-emulation/cadvisor/cadvisor-0.28.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/google/cadvisor"
+
+inherit user golang-build golang-vcs-snapshot
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Analyzes resource usage and performance characteristics of running containers"
+
+HOMEPAGE="https://github.com/google/cadvisor"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /dev/null ${PN}
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dobin ${PN}
+}