summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-01 16:31:09 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-01 16:31:09 +0200
commitf21cf0a7b9bbb72cbb3313538d675f47ece677ed (patch)
tree283543be06e162e699a99dc8e27a0c1fe146633b /app-emulation
parentx11-plugins/enigmail: Removed old. (diff)
downloadgentoo-f21cf0a7b9bbb72cbb3313538d675f47ece677ed.tar.gz
gentoo-f21cf0a7b9bbb72cbb3313538d675f47ece677ed.tar.bz2
gentoo-f21cf0a7b9bbb72cbb3313538d675f47ece677ed.zip
app-emulation/img: Version bump to 0.3.9
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/img/Manifest1
-rw-r--r--app-emulation/img/img-0.3.9.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
index 4b5ebf49c7dc..ff4269cc387f 100644
--- a/app-emulation/img/Manifest
+++ b/app-emulation/img/Manifest
@@ -1 +1,2 @@
DIST img-0.3.6.tar.gz 6043716 BLAKE2B 982a6f470f4b79cd4cc2b06be4060f516786f700872510948a25d5ad313cccf402b0fe26c053f7505b66c170221274568ce44632729c16e1ade680b5dc007b0d SHA512 911cf6a761741a04553d5e526399973c0e943cfda5eead7f94196969fed4f586134358b1e6f023c6cf07e755de802e498991eb320bd50af32649749622a26969
+DIST img-0.3.9.tar.gz 6153717 BLAKE2B b561ed349c2b08f0e3448886b6c979d86fd6d4f47af0f03d7dd479a12f078b99f39e10d6a6b3ba9caffe2a9966102e3f3069fa6eacb70bb36f9842314e8a8e7b SHA512 23bf1e85cb9238742ffef44408bece52b5b0fefbeae9541a7740a4d798d1dc2c0f8efd02d8342842753925135dee843c4a7a20abe3a87ce1c475178461c9b8da
diff --git a/app-emulation/img/img-0.3.9.ebuild b/app-emulation/img/img-0.3.9.ebuild
new file mode 100644
index 000000000000..661f99352151
--- /dev/null
+++ b/app-emulation/img/img-0.3.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="e4a43d044778e3df56e0de3c6ca00706fcca8b50"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags ${TAGS} -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}