summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2017-12-05 10:14:11 +0800
committerYixun Lan <dlan@gentoo.org>2017-12-05 10:24:30 +0800
commitf4fa9a8c31cb116b01a7f608af7fe3d68c829894 (patch)
tree81a534616dd4f5cc37a6f28bfa05f5eceb683261 /app-emulation
parentapp-emulation/xen: fix XSA-246,247 (diff)
downloadgentoo-f4fa9a8c31cb116b01a7f608af7fe3d68c829894.tar.gz
gentoo-f4fa9a8c31cb116b01a7f608af7fe3d68c829894.tar.bz2
gentoo-f4fa9a8c31cb116b01a7f608af7fe3d68c829894.zip
app-emulation/xen: obsolete epatch if EAPI=6
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen/xen-4.8.2-r3.ebuild17
-rw-r--r--app-emulation/xen/xen-4.9.1.ebuild20
2 files changed, 8 insertions, 29 deletions
diff --git a/app-emulation/xen/xen-4.8.2-r3.ebuild b/app-emulation/xen/xen-4.8.2-r3.ebuild
index 947c50c92242..d011e92de0cd 100644
--- a/app-emulation/xen/xen-4.8.2-r3.ebuild
+++ b/app-emulation/xen/xen-4.8.2-r3.ebuild
@@ -80,12 +80,7 @@ pkg_setup() {
src_prepare() {
# Upstream's patchset
- if [[ -n ${UPSTREAM_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-p1" \
- epatch "${WORKDIR}"/patches-upstream
- fi
+ [[ -n ${UPSTREAM_VER} ]] && eapply "${WORKDIR}"/patches-upstream
# Security patchset
if [[ -n ${SECURITY_VER} ]]; then
@@ -100,18 +95,14 @@ src_prepare() {
local i
for i in ${XEN_SECURITY_MAIN}; do
- epatch "${WORKDIR}"/patches-security/xen/$i
+ eapply "${WORKDIR}"/patches-security/xen/$i
done
fi
# Gentoo's patchset
- if [[ -n ${GENTOO_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patches-gentoo
- fi
+ [[ -n ${GENTOO_VER} ]] && eapply "${WORKDIR}"/patches-gentoo
- epatch "${FILESDIR}"/${PN}-4.6-efi.patch
+ eapply "${FILESDIR}"/${PN}-4.6-efi.patch
# Drop .config
sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
diff --git a/app-emulation/xen/xen-4.9.1.ebuild b/app-emulation/xen/xen-4.9.1.ebuild
index b9ad6439bc4a..cc0aedeffbcf 100644
--- a/app-emulation/xen/xen-4.9.1.ebuild
+++ b/app-emulation/xen/xen-4.9.1.ebuild
@@ -79,12 +79,7 @@ pkg_setup() {
src_prepare() {
# Upstream's patchset
- if [[ -n ${UPSTREAM_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-p1" \
- epatch "${WORKDIR}"/patches-upstream
- fi
+ [[ -n ${UPSTREAM_VER} ]] && eapply "${WORKDIR}"/patches-upstream
# Security patchset
if [[ -n ${SECURITY_VER} ]]; then
@@ -92,25 +87,18 @@ src_prepare() {
# apply main xen patches
# Two parallel systems, both work side by side
# Over time they may concdense into one. This will suffice for now
- EPATCH_SUFFIX="patch"
- EPATCH_FORCE="yes"
-
source "${WORKDIR}"/patches-security/${PV}.conf
local i
for i in ${XEN_SECURITY_MAIN}; do
- epatch "${WORKDIR}"/patches-security/xen/$i
+ eapply "${WORKDIR}"/patches-security/xen/$i
done
fi
# Gentoo's patchset
- if [[ -n ${GENTOO_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- epatch "${WORKDIR}"/patches-gentoo
- fi
+ [[ -n ${GENTOO_VER} ]] && eapply "${WORKDIR}"/patches-gentoo
- epatch "${FILESDIR}"/${PN}-4.6-efi.patch
+ eapply "${FILESDIR}"/${PN}-4.6-efi.patch
# Drop .config
sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"