summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElvis Pranskevichus <elvis@magic.io>2017-10-28 14:08:36 -0400
committerPatrice Clement <monsieurp@gentoo.org>2017-10-31 00:16:13 +0100
commit52b40decfae44e51376ff3756dbd0077e8380b90 (patch)
treef39a79332e541f80591e5f7e229fbb01c4c607fe /app-eselect/eselect-electron/eselect-electron-2.1.ebuild
parentapp-vim/jedi-vim: new ebuild. (diff)
downloadgentoo-52b40decfae44e51376ff3756dbd0077e8380b90.tar.gz
gentoo-52b40decfae44e51376ff3756dbd0077e8380b90.tar.bz2
gentoo-52b40decfae44e51376ff3756dbd0077e8380b90.zip
app-eselect/eselect-electron: version bump.
Closes: https://bugs.gentoo.org/632610 Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6066
Diffstat (limited to 'app-eselect/eselect-electron/eselect-electron-2.1.ebuild')
-rw-r--r--app-eselect/eselect-electron/eselect-electron-2.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-eselect/eselect-electron/eselect-electron-2.1.ebuild b/app-eselect/eselect-electron/eselect-electron-2.1.ebuild
new file mode 100644
index 000000000000..5a7856b25c22
--- /dev/null
+++ b/app-eselect/eselect-electron/eselect-electron-2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to select the default Electron slot"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://github.com/elprans/${PN}/archive/v${PV}.tar.gz -> eselect-electron-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins electron.eselect
+ dosym eselect /usr/bin/electron-config
+}
+
+pkg_postinst() {
+ electron-config update
+}