summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-eselect/eselect-lapack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-eselect/eselect-lapack')
-rw-r--r--app-eselect/eselect-lapack/eselect-lapack-0.1.ebuild26
-rw-r--r--app-eselect/eselect-lapack/files/lapack.eselect-0.115
-rw-r--r--app-eselect/eselect-lapack/files/lapack.eselect.567
-rw-r--r--app-eselect/eselect-lapack/metadata.xml5
4 files changed, 113 insertions, 0 deletions
diff --git a/app-eselect/eselect-lapack/eselect-lapack-0.1.ebuild b/app-eselect/eselect-lapack/eselect-lapack-0.1.ebuild
new file mode 100644
index 000000000000..78038b08518c
--- /dev/null
+++ b/app-eselect/eselect-lapack/eselect-lapack-0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="LAPACK module for eselect"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+# Need skel.bash lib
+RDEPEND=">=app-admin/eselect-1.0.5"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="lapack"
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}"/${MODULE}.eselect-${PVR} ${MODULE}.eselect
+ doman "${FILESDIR}"/lapack.eselect.5
+}
diff --git a/app-eselect/eselect-lapack/files/lapack.eselect-0.1 b/app-eselect/eselect-lapack/files/lapack.eselect-0.1
new file mode 100644
index 000000000000..f199692bd63d
--- /dev/null
+++ b/app-eselect/eselect-lapack/files/lapack.eselect-0.1
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit skel
+
+MODULE="LAPACK"
+IFACE="lapack"
+
+DESCRIPTION="Manage installed $MODULE implementations"
+MAINTAINER="spyderous@gentoo.org"
+SVN_DATE='$Date: 2015/03/31 16:49:51 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# vim: set ft=eselect :
diff --git a/app-eselect/eselect-lapack/files/lapack.eselect.5 b/app-eselect/eselect-lapack/files/lapack.eselect.5
new file mode 100644
index 000000000000..b682486ef82c
--- /dev/null
+++ b/app-eselect/eselect-lapack/files/lapack.eselect.5
@@ -0,0 +1,67 @@
+.TH "ESELECT" "5" "June 2006" "Gentoo Linux" "eselect"
+.SH "NAME"
+lapack.eselect \- The LAPACK management module for Gentoo's eselect
+.SH "SYNOPSIS"
+\fBeselect lapack\fR [\fBhelp\fR|\fBusage\fR]
+.br
+\fBeselect lapack\fR \fBlist\fR [\fIoptions\fR]
+.br
+\fBeselect lapack\fR \fBadd\fR
+.br
+\fBeselect lapack\fR \fBset\fR \fIimplementation\fR [\fIoptions\fR]
+.br
+\fBeselect lapack\fR \fBshow\fR [\fIoptions\fR]
+
+.SH "DESCRIPTION"
+\fBeselect\fR is Gentoo's configuration and management tool. It features
+modules that care for the individual administrative tasks.
+.SH "ACTION: LIST"
+\fBeselect lapack list\fR [\fIoptions\fR]
+.br
+Displays an ordered list of installed LAPACK implementations. It distinguishes between versions with different
+Application Binary Interfaces (e.g. x86/AMD64). Furthermore, it also distinguishes
+between interfaces to high-level programming languages. Each line holds
+a number and the implementation's name. An asterisk next to one of the list
+elements denotes an active implementation.
+
+phi / # eselect lapack list
+.br
+Installed LAPACK for libdir \fBlib\fR
+.br
+ [1] atlas *
+ [2] reference
+
+Possible \fIoptions\fR to the \fBlist\fR action are restrictions to
+handle only certain ABI\-specific library directories. For example,
+
+\fBeselect lapack list lib64\fR
+
+lists only LAPACK implementations found in \fB/usr/lib64\fR.
+
+.SH "ACTION: SHOW"
+\fBeselect lapack show\fR [\fIoptions\fR]
+.br
+Shows your system's currently active LAPACK implementations.
+
+phi / # eselect lapack show
+.br
+lib: atlas
+.br
+lib64: reference
+
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBshow\fR action to restrict it to given ABIs.
+.SH "ACTION: SET"
+\fBeselect lapack set\fR \fIimplementation\fR [\fIoptions\fR]
+.br
+Sets your system's currently active LAPACK implementations to \fIimplementation\fR.
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBset\fR action to restrict it to given ABIs.
+
+phi / # eselect lapack set atlas
+.SH "AUTHOR"
+Danny van Dyk <kugelfang@gentoo.org>
+.br
+Donnie Berkholz <spyderous@gentoo.org>
+.SH "REVISION"
+$Id$
diff --git a/app-eselect/eselect-lapack/metadata.xml b/app-eselect/eselect-lapack/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/app-eselect/eselect-lapack/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>