summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2020-12-07 21:31:00 -0500
committerBrian Evans <grknight@gentoo.org>2020-12-07 21:31:00 -0500
commit162e920a0c63a5bfe98805f7dce4a3354d8f3b3e (patch)
treee2f88fb0aa4eedc4dc0143ac0cb07e494742233d /app-eselect/eselect-php/eselect-php-0.9.7.ebuild
parentprofiles: add php_targets_php8-0 to stable mask (diff)
downloadgentoo-162e920a0c63a5bfe98805f7dce4a3354d8f3b3e.tar.gz
gentoo-162e920a0c63a5bfe98805f7dce4a3354d8f3b3e.tar.bz2
gentoo-162e920a0c63a5bfe98805f7dce4a3354d8f3b3e.zip
app-eselect/eselect-php: Version bump for 0.9.7
Includes PHP 8 support Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-php/eselect-php-0.9.7.ebuild')
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/eselect-php-0.9.7.ebuild b/app-eselect/eselect-php/eselect-php-0.9.7.ebuild
new file mode 100644
index 000000000000..c118dbec2492
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.9.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd autotools
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # We expect localstatedir to be "var"ish, not "var/lib"ish, because
+ # that's what PHP upstream expects. See for example the FPM
+ # configuration where they put logs in @localstatedir@/log.
+ #
+ # The libdir is passed explicitly in case the /usr/lib symlink
+ # is not present (bug 624528).
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --localstatedir="${EPREFIX}/var" \
+ --with-piddir="${EPREFIX}/run" \
+ $(use_enable apache2) \
+ $(use_enable fpm)
+}