summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2021-02-09 23:14:56 +0000
committerMikle Kolyada <zlogene@gentoo.org>2021-02-23 18:33:09 +0300
commitaa876f1a70835eceb5005a1175f48f448c5d959c (patch)
tree979a630e69749be0456ce81a8b7f6cdce3e7c105 /app-eselect/eselect-pinentry
parentdev-python/nototools: Support python 3.9 (diff)
downloadgentoo-aa876f1a70835eceb5005a1175f48f448c5d959c.tar.gz
gentoo-aa876f1a70835eceb5005a1175f48f448c5d959c.tar.bz2
gentoo-aa876f1a70835eceb5005a1175f48f448c5d959c.zip
app-eselect/eselect-pinentry: add pinentry-efl
As per https://git.gnupg.org/cgi-bin/gitweb.cgi?p=pinentry.git;a=blob;f=NEWS, pinentry 1.1.1 adds an EFL based pinentry. Closes: https://bugs.gentoo.org/767181 Signed-off-by: Bertrand Jacquin <bertrand@jacquin.bzh> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-pinentry')
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.2.ebuild23
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.212
2 files changed, 35 insertions, 0 deletions
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.2.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.2.ebuild
new file mode 100644
index 000000000000..b8dafabf64a4
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+S="${FILESDIR}"
+
+src_install() {
+ default
+ insinto /usr/share/eselect/modules
+ newins pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.2 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.2
new file mode 100644
index 000000000000..c445cbf79276
--- /dev/null
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.2
@@ -0,0 +1,12 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="zlogene@gentoo.org"
+VERSION="0.7.2"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=( pinentry-efl pinentry-gnome3 pinentry-qt5 pinentry-curses pinentry-tty )
+SYMLINK_DESCRIPTION='pinentry binary'
+
+inherit bin-symlink