summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-09 17:39:27 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-09 17:39:41 +0200
commit8513d37e2d745b9b1c65f9fb9b62c28dbd555129 (patch)
treefd06e799ce2694d25e377570a015b803bbf3ab2e /app-eselect
parentapp-emulation/libvirt-9999: Switch to meson (diff)
downloadgentoo-8513d37e2d745b9b1c65f9fb9b62c28dbd555129.tar.gz
gentoo-8513d37e2d745b9b1c65f9fb9b62c28dbd555129.tar.bz2
gentoo-8513d37e2d745b9b1c65f9fb9b62c28dbd555129.zip
app-eselect/eselect-sndpeek: fixed a typo in eselect script
Closes: https://bugs.gentoo.org/705678 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-sndpeek/Manifest1
-rw-r--r--app-eselect/eselect-sndpeek/eselect-sndpeek-1.0.2.ebuild (renamed from app-eselect/eselect-sndpeek/eselect-sndpeek-1.0.1.ebuild)6
-rw-r--r--app-eselect/eselect-sndpeek/files/sndpeek.eselect-1.0.2143
3 files changed, 146 insertions, 4 deletions
diff --git a/app-eselect/eselect-sndpeek/Manifest b/app-eselect/eselect-sndpeek/Manifest
deleted file mode 100644
index 01f24ecb2ad9..000000000000
--- a/app-eselect/eselect-sndpeek/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST sndpeek.eselect-1.0.1.bz2 1263 BLAKE2B ab2ed4019fd3bd991803375dd6219e4ca8bcade739c435beaf034d701324db52d12b0967821716351455f39d181657d6153d889cc313c2a3761994afbd79194d SHA512 39cc065d4fbe408db9c406d84a0ebf4a69a9c50f440f26b714b5f154bf7b5de497df4226434d60c0b1e4e073bbe3a0ca96c3bd574148772a4912e2fc9c9c6b5b
diff --git a/app-eselect/eselect-sndpeek/eselect-sndpeek-1.0.1.ebuild b/app-eselect/eselect-sndpeek/eselect-sndpeek-1.0.2.ebuild
index f9b2155ae3d9..0214ffce2cdf 100644
--- a/app-eselect/eselect-sndpeek/eselect-sndpeek-1.0.1.ebuild
+++ b/app-eselect/eselect-sndpeek/eselect-sndpeek-1.0.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Manages the /usr/bin/sndpeek symlink"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="mirror://gentoo/sndpeek.eselect-${PVR}.bz2"
+SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
@@ -18,5 +18,5 @@ S="${WORKDIR}"
src_install() {
insinto /usr/share/eselect/modules
- newins "${WORKDIR}/sndpeek.eselect-${PVR}" sndpeek.eselect
+ newins "${FILESDIR}/sndpeek.eselect-${PV}" sndpeek.eselect
}
diff --git a/app-eselect/eselect-sndpeek/files/sndpeek.eselect-1.0.2 b/app-eselect/eselect-sndpeek/files/sndpeek.eselect-1.0.2
new file mode 100644
index 000000000000..edb54442ceb6
--- /dev/null
+++ b/app-eselect/eselect-sndpeek/files/sndpeek.eselect-1.0.2
@@ -0,0 +1,143 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /usr/bin/sndpeek audio engine"
+MAINTAINER="cedk@gentoo.org"
+
+# find a list of sndpeek symlink targets, best first
+find_targets() {
+ local f
+ for f in \
+ ${ROOT}/usr/bin/sndpeek-alsa \
+ ${ROOT}/usr/bin/sndpeek-jack \
+ ${ROOT}/usr/bin/sndpeek-oss \
+ ; do
+ if [[ -f ${f} ]] ; then
+ echo $(basename ${f} )
+ fi
+ done
+}
+
+# try to remove the sndpeek symlink
+remove_symlinks() {
+ rm -f "${ROOT}"/usr/bin/sndpeek &>/dev/null
+}
+
+# set the sndpeek symlink
+set_symlinks() {
+ local target="${1}" targets
+ if is_number "${target}" && [[ ${target} -ge 1 ]] ; then
+ targets=( $(find_targets ) )
+ target=${targets[$(( ${target} - 1 ))]}
+ fi
+ if [[ -f "${ROOT}/usr/bin/${target}" ]] ; then
+ remove_symlinks
+
+ # it's not okay if these fail
+ ln -s "${ROOT}/usr/bin/${target}" "${ROOT}/usr/bin/sndpeek" || \
+ die "Couldn't set ${target} /usr/bin/sndpeek symlink"
+ else
+ die -q "Target \"${1}\" doesn't appear to be valid!"
+ fi
+}
+
+### show action ###
+
+describe_show() {
+ echo "Show the current sndpeek audio engine"
+}
+
+do_show() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ write_list_start "Current sndpeek audio engine:"
+ if [[ -L "${ROOT}/usr/bin/sndpeek" ]] ; then
+ write_kv_list_entry "$(basename $(canonicalise ${ROOT}/usr/bin/sndpeek ) )" ""
+ elif [[ -e "${ROOT}/usr/bin/sndpeek" ]] ; then
+ write_kv_list_entry "(not a symlink)" ""
+ else
+ write_kv_list_entry "(unset)" ""
+ fi
+}
+
+### list action ###
+
+describe_list() {
+ echo "List available sndpeek audio engines"
+}
+
+do_list() {
+ [[ -z "${@}" ]] || die -q "Too many parameters"
+
+ local i targets
+ targets=( $(find_targets ) )
+ write_list_start "Available sndpeek audio engines:"
+ for (( i = 0 ; i < ${#targets[@]} ; i = i + 1 )) ; do
+ [[ ${targets[${i}]} == $(basename $(canonicalise ${ROOT}/usr/bin/sndpeek ) ) ]] && \
+ targets[${i}]=$(highlight_marker "${targets[${i}]}")
+ done
+ write_numbered_list -m "(none found)" "${targets[@]}"
+}
+
+### set action ###
+
+describe_set() {
+ echo "Set a new sndpeek audio engines"
+}
+
+describe_set_options() {
+ echo "target : Target name or number (from 'list' action)"
+}
+
+describe_set_parameters() {
+ echo "<target>"
+}
+
+do_set() {
+ if [[ -z "${1}" ]] ; then
+ die -q "You didn't give me an audio engine"
+
+ elif [[ -n "${2}" ]] ; then
+ die -q "Too many parameters"
+
+ elif [[ -L "${ROOT}/usr/bin/sndpeek" ]] ; then
+ if ! remove_symlinks ; then
+ die -q "Can't remove existing provider"
+ elif ! set_symlinks "${1}" ; then
+ die -q "Can't set new provider"
+ fi
+
+ elif [[ -e "${ROOT}/usr/bin/sndpeek" ]] ; then
+ die -q "Sorry, ${ROOT}/usr/bin/sndpeek confuses me"
+
+ else
+ set_symlinks "${1}" || die -q "Can't set a new audio engine"
+ fi
+}
+
+### update action ###
+
+describe_update() {
+ echo "Automatically update the audio engine"
+}
+
+describe_update_options() {
+ echo "--if-unset : Do not override existing audio engine"
+}
+
+do_update() {
+ [[ -z "${1}" ]] || ( [[ -z "${2}" ]] && [[ "${1}" == "--if-unset" ]] ) || \
+ die -q "Usage error"
+
+ if [[ -L "${ROOT}/usr/bin/sndpeek" ]] ; then
+ [[ ${1} == "--if-unset" ]] && return
+ remove_symlinks || die -q "Can't remove existing link"
+ fi
+ if [[ -e "${ROOT}/usr/bin/sndpeek" ]] ; then
+ die -q "Can't set a new provider"
+ elif ! [[ -z $(find_targets ) ]] ; then
+ set_symlinks 1 || die -q "Can't set a new provider"
+ fi
+}
+
+# vim: set ft=eselect :