summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-17 00:01:22 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-17 00:10:25 -0700
commit945b7b855d6bfd8aaa2be9ff53f49a5c5f77c94a (patch)
tree96ffd8a7e6f630395b473ae1e617ac8f83a1f67e /app-eselect
parentnet-ftp/proftpd: remove unused patches (diff)
downloadgentoo-945b7b855d6bfd8aaa2be9ff53f49a5c5f77c94a.tar.gz
gentoo-945b7b855d6bfd8aaa2be9ff53f49a5c5f77c94a.tar.bz2
gentoo-945b7b855d6bfd8aaa2be9ff53f49a5c5f77c94a.zip
app-eselect/eselect-java: bump to 0.4.1
Bug: https://bugs.gentoo.org/742335 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-java/Manifest1
-rw-r--r--app-eselect/eselect-java/eselect-java-0.4.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-eselect/eselect-java/Manifest b/app-eselect/eselect-java/Manifest
index 413648787cd6..b1a60adfae20 100644
--- a/app-eselect/eselect-java/Manifest
+++ b/app-eselect/eselect-java/Manifest
@@ -1 +1,2 @@
DIST eselect-java-0.4.0.tar.xz 13412 BLAKE2B da3df5c342b1632d1cc597909283cfcb7cb71d4bff04c2aa3253110f06b8addc5121efe1a50409f2b297c70c4f816a385a0199e68821acb6c48e3065d3097b37 SHA512 a1bdb2554e4dc78d980cab80591f6e0c537f983ae78d2ca98bda8f5292cf749fa5a9983dc51c6576176566f2fcc255ca40b04c26bd1b5d7f1db2d12b76048567
+DIST eselect-java-0.4.1.tar.bz2 13737 BLAKE2B e1b0c9a0f1ca08efe47c14aeabb152b7c02cef028d1e62914199896fe70c978f2851f899ec8dd233be5ec86c62d55f250c9360f6b8932f11288b75a4334732b2 SHA512 0a47a448d75a006e1bf117817f73eebcb586f4da2e597663eaaa00824b1bcfb2779c06bf8bc6e83df6d7993fe28fbe02d3b259b4c6cf3e5c2792b999097fcbe8
diff --git a/app-eselect/eselect-java/eselect-java-0.4.1.ebuild b/app-eselect/eselect-java/eselect-java-0.4.1.ebuild
new file mode 100644
index 000000000000..396c12444044
--- /dev/null
+++ b/app-eselect/eselect-java/eselect-java-0.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A set of eselect modules for Java"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Java"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ !app-eselect/eselect-ecj
+ !app-eselect/eselect-maven
+ !<dev-java/java-config-2.2
+ app-admin/eselect"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ local REMOVED=0
+
+ rm -v "${EROOT}"/usr/lib*/nsbrowser/plugins/javaplugin.so 2>/dev/null && REMOVED=1
+ rm -v "${EROOT}"/etc/java-config-2/current-icedtea-web-vm 2>/dev/null && REMOVED=1
+
+ if [[ ${REMOVED} = 1 ]]; then
+ elog "The eselect java-nsplugin module has been removed and your configuration"
+ elog "has been cleaned up. From now on, you may only install either Oracle or"
+ elog "IcedTea's plugin but not both. Note you can use IcedTea's plugin with an"
+ elog "Oracle VM. See the README installed with icedtea-web for more details."
+ fi
+}