summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-29 14:52:07 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-29 14:52:07 +0200
commita824663636768c74d61b211d247ef203964768f3 (patch)
treeabc3ccf9e9d05f1315dddbb860de8a504b8bc984 /app-eselect
parentxfce-extra/xfce4-cpugraph-plugin: Bump to 1.0.90 (GTK+3 port) (diff)
downloadgentoo-a824663636768c74d61b211d247ef203964768f3.tar.gz
gentoo-a824663636768c74d61b211d247ef203964768f3.tar.bz2
gentoo-a824663636768c74d61b211d247ef203964768f3.zip
app-eselect/eselect-repository: Bump to v7
Closes: https://bugs.gentoo.org/686926 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-repository/Manifest1
-rw-r--r--app-eselect/eselect-repository/eselect-repository-7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-eselect/eselect-repository/Manifest b/app-eselect/eselect-repository/Manifest
index 2053b4e0a0e3..61c234d7fca0 100644
--- a/app-eselect/eselect-repository/Manifest
+++ b/app-eselect/eselect-repository/Manifest
@@ -1 +1,2 @@
DIST eselect-repository-6.tar.gz 5605 BLAKE2B 4a6dbb3f573cb1c4e212d02d011e79d8522828b8928bf28016b616c8eefd3beb08db8b555728d4e7f83473f2d36395eb1e2f1d8d21ccd5817e38a5d555cf6f09 SHA512 02ca2d66a6cfe4c68dea780440bf7fd431c575e535139a43c2b6201e833e43d174772486c97dc4154fc2d813935079d36c116ee907db115f7cb281db3d72add7
+DIST eselect-repository-7.tar.gz 6768 BLAKE2B f648b880ab188b5beb21161dd011d8cea0bc9dd124d524d747a1867a37f334667363be9c0ad9f04275aa1534b904a519d7551c25ea547ae2acff625382c35dbd SHA512 87569158dce3acfdd81a469387fe1a7a7c268cae2e15cfdb12d8377984be5feb674c9b385f0171d27dbe8c2066ae98b2c9a74214340e85380cba173ba26d6f0f
diff --git a/app-eselect/eselect-repository/eselect-repository-7.ebuild b/app-eselect/eselect-repository/eselect-repository-7.ebuild
new file mode 100644
index 000000000000..1e3790748b61
--- /dev/null
+++ b/app-eselect/eselect-repository/eselect-repository-7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+inherit python-single-r1
+
+DESCRIPTION="Manage repos.conf via eselect"
+HOMEPAGE="https://github.com/mgorny/eselect-repository"
+SRC_URI="https://github.com/mgorny/eselect-repository/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-admin/eselect
+ dev-python/lxml[${PYTHON_USEDEP}]
+ net-misc/wget"
+
+src_compile() {
+ MAKEARGS=(
+ PREFIX="${EPREFIX}/usr"
+ SYSCONFDIR="${EPREFIX}/etc"
+ SHAREDSTATEDIR="${EPREFIX}/var"
+ ESELECTDIR="${EPREFIX}/usr/share/eselect/modules"
+ )
+
+ emake "${MAKEARGS[@]}"
+ python_fix_shebang eselect-repo-helper
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ keepdir /var/db/repos
+ einstalldocs
+}