summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-25 19:29:20 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-26 11:57:35 -0400
commita9381c2a5c65c0f8020e587b6ab1f8f0c43ef446 (patch)
treea3d5e137f27ddb35abe8da1620fcc628447e2006 /app-eselect
parentsci-mathematics/form: bump to 4.2.0 (diff)
downloadgentoo-a9381c2a5c65c0f8020e587b6ab1f8f0c43ef446.tar.gz
gentoo-a9381c2a5c65c0f8020e587b6ab1f8f0c43ef446.tar.bz2
gentoo-a9381c2a5c65c0f8020e587b6ab1f8f0c43ef446.zip
app-eselect/eselect-php: new version 0.9.3.
Gentoo-Bug: 624528 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-php/Manifest1
-rw-r--r--app-eselect/eselect-php/eselect-php-0.9.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-eselect/eselect-php/Manifest b/app-eselect/eselect-php/Manifest
index ca18cbf5af6e..d755ce58acb2 100644
--- a/app-eselect/eselect-php/Manifest
+++ b/app-eselect/eselect-php/Manifest
@@ -1 +1,2 @@
DIST eselect-php-0.9.2.tar.xz 48356 SHA256 8b2acfccb3d2e3d7cad137fc4306711371ebd544cbcdad8e9d46c5dacf8ed889 SHA512 ebf4c9039aaa3ffad79dee181b5cd77f144a4b1b49d80291b290377b7ca5a9618d8b18922f0624e646c4d80266c58199bb936a7b8dd5d2e2bdc296099f583edf WHIRLPOOL 5ca0673a80b5e88522ff1ca82c4b4f842a63439cd47562c72048a4d66dc88d2dcc7070c28c0b8ff50a75bdb1a9056ee5391b37f4dc34cc9eda3652c6791a276c
+DIST eselect-php-0.9.3.tar.xz 49532 SHA256 b35e12f371ad94a08f83fd05520bb2205ae9299080b42b5b632ac7eb62f9c612 SHA512 fb22610ba67b220b08d8b52ca9567806521041587c3e72da2a73f85b87bce81b6e5ec26485f676108004a370ac639c23e732dda78ed276f84d8f38470e7643f3 WHIRLPOOL d77a13068d35d7c06e7b2f265d4c25f68a83aff6c77fb6446f46a7f18b0d107e8274968ef38f1f8baec94d3fee417ef2b58e0eb3b3ea77a627ead5db55ffbfac
diff --git a/app-eselect/eselect-php/eselect-php-0.9.3.ebuild b/app-eselect/eselect-php/eselect-php-0.9.3.ebuild
new file mode 100644
index 000000000000..a05df2fe1bb9
--- /dev/null
+++ b/app-eselect/eselect-php/eselect-php-0.9.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
+SRC_URI="https://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
+RDEPEND="app-admin/eselect
+ apache2? ( www-servers/apache[apache2_modules_dir] )
+ fpm? ( sys-apps/gentoo-functions )"
+
+src_configure(){
+ # We expect localstatedir to be "var"ish, not "var/lib"ish, because
+ # that's what PHP upstream expects. See for example the FPM
+ # configuration where they put logs in @localstatedir@/log.
+ #
+ # The libdir is passed explicitly in case the /usr/lib symlink
+ # is not present (bug 624528).
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --localstatedir="${EPREFIX}/var" \
+ --with-piddir="${EPREFIX}/run" \
+ $(use_enable apache2) \
+ $(use_enable fpm)
+}
+
+src_install() {
+ default
+
+ # This can be removed after a while...
+ if use apache2 ; then
+ insinto /etc/apache2/modules.d
+ newins "${FILESDIR}/70_mod_php5.backcompat.conf" 70_mod_php5.conf
+ fi
+
+ if use fpm ; then
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ newexe "${FILESDIR}/php-fpm-launcher-r1" php-fpm-launcher
+ fi
+}
+
+pkg_postinst() {
+ if use apache2 ; then
+ elog
+ elog "If you are upgrading, be warned that our mod_php configuration"
+ elog "file has changed! You should now define -DPHP for the apache2"
+ elog "daemon, and inspect the new 70_mod_php.conf which has been"
+ elog "installed. Module loading involves eselect as of this version."
+ elog
+ elog "You must run eselect at least once to choose your apache2 target"
+ elog "before the new configuration will work. Afterwards, and after you"
+ elog "have reviewed your new configuration, you are advised to remove"
+ elog "the obsolete 70_mod_php5.conf file."
+ elog
+ fi
+}