summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-13 11:48:11 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-13 11:48:36 +0100
commitebde59a375defce263126cc8bee4779c070e43eb (patch)
tree338f404633f3f5042a101aa61070659d1dd7495c /app-forensics/afflib
parentapp-text/hunspell: Bump to version 1.7.0 (diff)
downloadgentoo-ebde59a375defce263126cc8bee4779c070e43eb.tar.gz
gentoo-ebde59a375defce263126cc8bee4779c070e43eb.tar.bz2
gentoo-ebde59a375defce263126cc8bee4779c070e43eb.zip
app-forensics/afflib: Bump to version 3.7.17
which also fixes build with openssl-1.1 Closes: https://bugs.gentoo.org/671060 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-forensics/afflib')
-rw-r--r--app-forensics/afflib/Manifest1
-rw-r--r--app-forensics/afflib/afflib-3.7.17.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-forensics/afflib/Manifest b/app-forensics/afflib/Manifest
index c696cff8d13a..41d498f0278e 100644
--- a/app-forensics/afflib/Manifest
+++ b/app-forensics/afflib/Manifest
@@ -1,3 +1,4 @@
+DIST afflib-3.7.17.tar.gz 533720 BLAKE2B da38d29b7dedc07a7594f24e263e04645aa0f04e561af1f31e54a40c76e62d8eff0e815ee5592d1bfe2e8873fc53701f0126bf0d0b595ce2df5d61f8bb52dc8c SHA512 21067a8cb7c7b3d75f91883b2f9b1c978e055a2df6331dc68245332226d042a6b82f9f5d996e6bd1d5155de511827d5636c75ab1ee0a6957815aab3bb1cff49b
DIST afflib-3.7.4.tar.gz 569346 BLAKE2B e296bf58499bff4d44c9f5e1dd7363b4a68581213ff04ab14ffbe35b877c8307da03fb49e967a722ad9869f6284de496b86258f1b20c7c9e6b6a6cdcf473a03f SHA512 58791388a05d614dd5f219a74173de2ff0938a1f93b21e2dd0731aca52ea544ba60cc4325f0d284937467ce600a4302b7a2f724d84710ecc7f12db1a22a8e41c
DIST afflib-3.7.7.tar.gz 518933 BLAKE2B a32a1954acfeed4d2c8db2bb3f1ee99e5177b2f84d0037f851fda095b47a1d3ca2dc81221d9fbbb040a866f86c4aebded0cbc31353a9cda0a0e81096baada28a SHA512 8698d66ab84601e5dcd64fcedf2087d5a8227895ed4009d314958eb223c56e0e59aa3e76d57f854a911f79194ae9c1ffc8af8e686310752744b43030c9e84e80
DIST afflib-3.7.8.tar.gz 518399 BLAKE2B 80bc168d63ff53d8f3c60aeb2a1f0d25eec39a1d850095f694a11b755d3a0cc9765be4ed076d07cb98185e8375004d12592d14c1fc370c95a15f054d02f96a55 SHA512 a547ea459c479ccba1b4805bcbbac6f670abdccf8fe6685406d0662483a2b643652e3798e6396ecb24cfeea9bf711f636aeebb64794637ee54e7dbb62c0bdbb7
diff --git a/app-forensics/afflib/afflib-3.7.17.ebuild b/app-forensics/afflib/afflib-3.7.17.ebuild
new file mode 100644
index 000000000000..b83099399703
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.7.17.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit autotools python-single-r1
+
+MY_PN=AFFLIBv3
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="https://github.com/sshock/AFFLIBv3/"
+SRC_URI="https://github.com/sshock/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~x64-macos"
+IUSE="fuse libressl ncurses python qemu readline s3 static-libs threads"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="dev-libs/expat
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse:= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ ncurses? ( sys-libs/ncurses:0= )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ s3? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i '/FLAGS/s: -g::' configure.ac || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Hacks for automagic dependencies
+ use ncurses || export ac_cv_lib_ncurses_initscr=no
+ use readline || export ac_cv_lib_readline_readline=no
+
+ local myeconfargs=(
+ $(use_enable fuse)
+ $(use_enable python)
+ $(use_enable qemu)
+ $(use_enable s3)
+ $(use_enable static-libs static)
+ $(use_enable threads threading)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}