summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-25 13:02:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-25 13:03:07 +0100
commit1d0e49d8c7f60d5a3be7e8d68e5976225a337e85 (patch)
tree09db057d2c915e7bb44973ada528e1e61bc9d369 /app-forensics/chkrootkit
parentprofiles: Clean stale/incorrect masks up (diff)
downloadgentoo-1d0e49d8c7f60d5a3be7e8d68e5976225a337e85.tar.gz
gentoo-1d0e49d8c7f60d5a3be7e8d68e5976225a337e85.tar.bz2
gentoo-1d0e49d8c7f60d5a3be7e8d68e5976225a337e85.zip
app-forensics/chkrootkit: Bump to version 0.54
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-forensics/chkrootkit')
-rw-r--r--app-forensics/chkrootkit/Manifest2
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.54.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-forensics/chkrootkit/Manifest b/app-forensics/chkrootkit/Manifest
index 7c2d8b1964e2..dd974a17d358 100644
--- a/app-forensics/chkrootkit/Manifest
+++ b/app-forensics/chkrootkit/Manifest
@@ -1,2 +1,4 @@
DIST chkrootkit-0.53-gentoo.diff.xz 4844 BLAKE2B b4f0077989e032154f190f6bad98e8882390a2ac7e144a2c755fbeb560c809c8289563e57dd8fda23eca07dcb1b3e59d6fb016e72ecbb29d184fdf8feb4949d0 SHA512 664c203b093fb91963bae8f70d5711dfd0023c789ddd4265031c84f91f01a53b3b28757cd08b8633c3f6c184a257616b05bc12d8c84202ff98db523aaff5a6f3
DIST chkrootkit-0.53.tar.gz 40483 BLAKE2B ee78afc5bb5453fe7b30d966988060a68b7286fce0f87fb76d8ea3b1dd548c287c8bfc6f0772e05e6eee362af873148399a0a8af91d48765e542970dc3149c9d SHA512 f8de19d0a61ccb6ac184ad6642d78041729cba799eedcc8088cb6d2c5cf4de0574c6083caad364576a601265322e61c183b266304f00667527bf29fdc51359c7
+DIST chkrootkit-0.54-gentoo.diff.xz 4848 BLAKE2B 25d1736bb839533fae36550518b311e52bb38f8a562a63d40629789dc9497b6e71dbc306d1f845b6a5cd586468afa6a7ac4ce8b6f1bfb40d7ac9b0331a55def9 SHA512 6c972b081794681b61b7c67f9a5762ba5d2c0c731c9a2bf9f75e715984edf7022ddcd44d34803eacb58a59e8b21932ffb586cc9fb7998a43393367c2530e353e
+DIST chkrootkit-0.54.tar.gz 41461 BLAKE2B 61384fda7db08ca2a52ab060ee4ea3edb7311cb9908599a511459dac22340f28e75d732b10d827aaeed89a1ecb6fc7f69ab8fef970aae5a73bae8c7949944831 SHA512 fe8955ac33abaabf304f5580b6f12929f8bf02329ab442380eaa6298440cf1cb0eee2db8e5667ea7d78b89ee2bceb82c10ebb732a71d6bcdda9400569cd587fd
diff --git a/app-forensics/chkrootkit/chkrootkit-0.54.ebuild b/app-forensics/chkrootkit/chkrootkit-0.54.ebuild
new file mode 100644
index 000000000000..363908d719bd
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.54.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+GENTOO_PATCH="${PN}-0.54-gentoo.diff"
+
+DESCRIPTION="Tool to locally check for signs of a rootkit"
+HOMEPAGE="http://www.chkrootkit.org/"
+SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz
+ https://dev.gentoo.org/~polynomial-c/${GENTOO_PATCH}.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="+cron"
+
+RDEPEND="cron? ( virtual/cron )"
+
+PATCHES=(
+ "${WORKDIR}/${GENTOO_PATCH}"
+)
+
+src_prepare() {
+ default
+ sed -e 's:/var/adm/:/var/log/:g' \
+ -i chklastlog.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=true sense
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
+ dodoc ACKNOWLEDGMENTS README*
+
+ if use cron ; then
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/${PN}.cron ${PN}
+ fi
+}
+
+pkg_postinst() {
+ if use cron ; then
+ elog
+ elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog
+ fi
+
+ elog
+ elog "Some applications, such as portsentry, will cause chkrootkit"
+ elog "to produce false positives. Read the chkrootkit FAQ at"
+ elog "http://www.chkrootkit.org/ for more information."
+ elog
+}