summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-13 05:35:42 +0000
committerSam James <sam@gentoo.org>2022-01-13 05:35:42 +0000
commite0b5d87f903b7c55b3d1f37c93ec0fa09c7fe937 (patch)
tree56a769ea7db6d479a3c492f1e04d44b7a4823afa /app-forensics/chkrootkit
parentsys-process/atop: add note re upstreamed OpenRC init scripts (diff)
downloadgentoo-e0b5d87f903b7c55b3d1f37c93ec0fa09c7fe937.tar.gz
gentoo-e0b5d87f903b7c55b3d1f37c93ec0fa09c7fe937.tar.bz2
gentoo-e0b5d87f903b7c55b3d1f37c93ec0fa09c7fe937.zip
app-forensics/chkrootkit: fix systemd notice
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics/chkrootkit')
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.55-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-forensics/chkrootkit/chkrootkit-0.55-r1.ebuild b/app-forensics/chkrootkit/chkrootkit-0.55-r1.ebuild
index 03cfffb6ef30..0bfac68e7a96 100644
--- a/app-forensics/chkrootkit/chkrootkit-0.55-r1.ebuild
+++ b/app-forensics/chkrootkit/chkrootkit-0.55-r1.ebuild
@@ -15,11 +15,9 @@ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${GENTOO_PATC
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="+cron systemd"
+IUSE="+cron"
-DEPEND="systemd? ( sys-apps/systemd )"
-RDEPEND="${DEPEND}
- cron? ( virtual/cron )"
+RDEPEND="cron? ( virtual/cron )"
PATCHES=(
"${WORKDIR}/${GENTOO_PATCH}"
@@ -29,6 +27,7 @@ PATCHES=(
src_prepare() {
default
+
sed -e 's:/var/adm/:/var/log/:g' \
-i chklastlog.c || die
}
@@ -45,21 +44,24 @@ src_install() {
exeinto /etc/cron.weekly
newexe "${FILESDIR}"/${PN}.cron ${PN}
fi
+
systemd_dounit "${FILESDIR}/${PN}.timer" "${FILESDIR}/${PN}.service"
}
pkg_postinst() {
if use cron ; then
elog
- elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog "Edit ${EROOT}/etc/cron.weekly/chkrootkit to activate chkrootkit!"
elog
fi
- if use systemd ; then
+
+ if systemd_is_booted || has_version sys-apps/systemd ; then
elog
elog "To enable the systemd timer, run the following command:"
elog " systemctl enable --now chkrootkit.timer"
elog
fi
+
elog
elog "Some applications, such as portsentry, will cause chkrootkit"
elog "to produce false positives. Read the chkrootkit FAQ at"