summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2017-05-28 10:34:45 +0100
committerMike Auty <ikelos@gentoo.org>2017-05-28 10:35:35 +0100
commit014d83968309be28a94292a677a0d55a02e9d0fc (patch)
treedbbb2c3eeffaed85392952f82edd0379eda1c727 /app-forensics/foremost/foremost-1.5.7-r3.ebuild
parentkde5.eclass: Don't remove cmake_modules, simplify filtering LINGUAS (diff)
downloadgentoo-014d83968309be28a94292a677a0d55a02e9d0fc.tar.gz
gentoo-014d83968309be28a94292a677a0d55a02e9d0fc.tar.bz2
gentoo-014d83968309be28a94292a677a0d55a02e9d0fc.zip
app-forensics/foremost: Uncompress man page before using doman.
Remove the version of foremost missing the security patch and add a new unstable version to uncompress the man page before using doman on it (bug 619928). Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-forensics/foremost/foremost-1.5.7-r3.ebuild')
-rw-r--r--app-forensics/foremost/foremost-1.5.7-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-forensics/foremost/foremost-1.5.7-r3.ebuild b/app-forensics/foremost/foremost-1.5.7-r3.ebuild
new file mode 100644
index 000000000000..69d67a469d2d
--- /dev/null
+++ b/app-forensics/foremost/foremost-1.5.7-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A console program to recover files based on their headers and footers"
+HOMEPAGE="http://foremost.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+# starting to hate sf.net ...
+SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+LICENSE="public-domain"
+SLOT="0"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.4-config-location.patch"
+ epatch "${FILESDIR}/${PN}-1.5.7-format-security.patch"
+ default_src_prepare
+}
+
+src_compile() {
+ emake RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ CONF=/etc
+}
+
+src_install() {
+ dobin foremost
+ gunzip foremost.8.gz
+ doman foremost.8
+ insinto /etc
+ doins foremost.conf
+ dodoc README CHANGES
+}