summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-29 23:18:15 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-29 23:33:07 +0100
commit815909f0ea4fb03f9ce91e8738e84843c574bb50 (patch)
treed1f9fe5e223e8bc144525bc1c53a01709443908d /app-forensics/galleta
parentapp-forensics/rifiuti: Port to EAPI 6 (diff)
downloadgentoo-815909f0ea4fb03f9ce91e8738e84843c574bb50.tar.gz
gentoo-815909f0ea4fb03f9ce91e8738e84843c574bb50.tar.bz2
gentoo-815909f0ea4fb03f9ce91e8738e84843c574bb50.zip
app-forensics/galleta: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-forensics/galleta')
-rw-r--r--app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch11
-rw-r--r--app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch12
-rw-r--r--app-forensics/galleta/galleta-20040505_p1.ebuild21
3 files changed, 37 insertions, 7 deletions
diff --git a/app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch b/app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..396739d358fc
--- /dev/null
+++ b/app-forensics/galleta/files/galleta-20040505_p1-Wimplicit-function-declaration.patch
@@ -0,0 +1,11 @@
+--- a/galleta.c
++++ b/galleta.c
+@@ -35,6 +35,8 @@
+ #include <stdio.h>
+ #include <time.h>
+ #include <math.h>
++#include <stdlib.h>
++#include <string.h>
+
+ #define STRSIZE 1000
+
diff --git a/app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch b/app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch
new file mode 100644
index 000000000000..125643c894df
--- /dev/null
+++ b/app-forensics/galleta/files/galleta-20040505_p1-fix-build-system.patch
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,6 @@
+-all: install
++LDLIBS += -lm
+
+-install: galleta.c
+- gcc -o galleta galleta.c -lm -lc;cp galleta ../bin
++all: galleta
+
+ installwin: galleta.c
+ gcc -DCYGWIN -o galleta.exe galleta.c -lm -lc;cp galleta.exe ../bin
diff --git a/app-forensics/galleta/galleta-20040505_p1.ebuild b/app-forensics/galleta/galleta-20040505_p1.ebuild
index 890ad5ab0d30..9192b6bdb8cb 100644
--- a/app-forensics/galleta/galleta-20040505_p1.ebuild
+++ b/app-forensics/galleta/galleta-20040505_p1.ebuild
@@ -1,25 +1,32 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
MY_P=${PN}_${PV/_p/_}
+
DESCRIPTION="IE Cookie Parser"
HOMEPAGE="https://sourceforge.net/projects/odessa/"
SRC_URI="mirror://sourceforge/odessa/${MY_P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE=""
-S=${WORKDIR}/${MY_P}
+S=${WORKDIR}/${MY_P}/src
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-build-system.patch
+ "${FILESDIR}"/${P}-Wimplicit-function-declaration.patch
+)
-src_compile() {
- cd src
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o galleta galleta.c -lm -lc || die "failed to compile"
+src_configure() {
+ tc-export CC
}
src_install() {
- dodoc Readme.txt
- dobin src/galleta
+ dobin ${PN}
+ dodoc ../{CHANGES,Readme.txt}
}