summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-04-12 20:53:48 -0400
committerTim Harder <radhermit@gentoo.org>2018-04-12 21:28:56 -0400
commit750940bd218774fa8ce3ca0c65894b99dfde48c1 (patch)
treee3c6330a9e38daaeca2d30a0fb64096842a130e3 /app-forensics
parentdev-python/cryptography: fix building with LibreSSL (diff)
downloadgentoo-750940bd218774fa8ce3ca0c65894b99dfde48c1.tar.gz
gentoo-750940bd218774fa8ce3ca0c65894b99dfde48c1.tar.bz2
gentoo-750940bd218774fa8ce3ca0c65894b99dfde48c1.zip
app-forensics/libewf: version bump to 20171104
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/Manifest1
-rw-r--r--app-forensics/libewf/libewf-20171104.ebuild56
-rw-r--r--app-forensics/libewf/metadata.xml5
3 files changed, 61 insertions, 1 deletions
diff --git a/app-forensics/libewf/Manifest b/app-forensics/libewf/Manifest
index b6ddeb6103ea..3c2cb5ad78ee 100644
--- a/app-forensics/libewf/Manifest
+++ b/app-forensics/libewf/Manifest
@@ -1,3 +1,4 @@
DIST libewf-20130416.tar.gz 1968288 BLAKE2B a61cd2239bfc12b1107bf3c6f68106027a1b08ca644dd8d8ca9dda331f902d1ba2e74dc516a3ed1dbf90f2926c7f654496bf6dd103d5c3f615bab653c8616fd0 SHA512 e84e920dfe6e5a313bc165b1796ab9681c5b42fdefc7120b4f1c0f4e42b220d8192e03df2707051cf16f4cc991facdfdbd39042dcfb645ac7a27b549e02bd96e
DIST libewf-20140608-libuna-remove-inline.patch 34909 BLAKE2B e0b4fdcdf3e791992f32bd5251d3a5e6c8d193fe33508620e040ae11c83cf0c308ffd9cce31b548be03e6ec3c0a0623eb25a1731d402296908923d2c6643bbc0 SHA512 01b82d1ebe921a3b572ba061886bddc76d57c6e13f7997ca139baf790d3be7a8e855a50a05915788a7afb85afd46f9cd638c279ba57f7c36398dadd94bc32fc7
DIST libewf-20140608.tar.gz 2129518 BLAKE2B aaa8e95f243e887494c5a50c1706864b4613e5731aa49ec2d2510b81984be9df70eeb18c1d5c56f97894536d55a16c2496eae8c662f6ab54e29c142f460fb188 SHA512 f77f01e3452027bff71e644708744e0774e1e397c70e2ebd687983730f03ffb01b26fec782bec79971e149caac5029484f3d9073c3a8042df951bfc542fe2436
+DIST libewf-experimental-20171104.tar.gz 2243405 BLAKE2B 86e69eba5313dadbfe2cc63639e96cf964b5d72e3c98299c0262547b2d900b7a8a4a5938435bdafac3890ee05ea0079ef68809086234ff486c985d557d2c4897 SHA512 610174971b8e09385f1f51c02e7be36e7a18d21f8b22ddeb7ba7d5c20e7df97591a70de3523b2d63bed8deb5a2a170a14e825f6a80aeb0937553ecae5925ee0b
diff --git a/app-forensics/libewf/libewf-20171104.ebuild b/app-forensics/libewf/libewf-20171104.ebuild
new file mode 100644
index 000000000000..010f601384f9
--- /dev/null
+++ b/app-forensics/libewf/libewf-20171104.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="https://github.com/libyal/libewf"
+SRC_URI="https://github.com/libyal/libewf/releases/download/${PV}/${PN}-experimental-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python unicode"
+IUSE="bfio bzip2 debug +fuse nls +ssl static-libs +uuid unicode zlib"
+
+# uses bundled libbfio until tree version is bumped
+RDEPEND="
+ fuse? ( sys-fs/fuse:0= )
+ nls? (
+ virtual/libintl
+ virtual/libiconv
+ )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+# issues finding test executables
+RESTRICT="test"
+
+src_configure() {
+ local econfargs=(
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ $(use_enable debug verbose-output)
+ $(use_enable debug debug-output)
+ $(use_enable unicode wide-character-type)
+ $(use_with bfio libbfio)
+ $(use_with zlib)
+ $(use_with bzip2)
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}
diff --git a/app-forensics/libewf/metadata.xml b/app-forensics/libewf/metadata.xml
index a4f3a69c3044..b18a991426db 100644
--- a/app-forensics/libewf/metadata.xml
+++ b/app-forensics/libewf/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
<use>
<flag name="bfio">Enables libbfio for chaining file in file handling</flag>
<flag name="rawio">Enables raw IO handling</flag>