summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 17:32:55 +0100
committerSam James <sam@gentoo.org>2022-04-17 17:32:55 +0100
commit7a8bbf0dd9baec1faffb463852d41a178585b38e (patch)
tree5fc7b101b532932c0fa314b3f58d6a9bc1e30fdb /app-forensics
parentapp-forensics/aflplusplus: update EAPI 7 -> 8 (diff)
downloadgentoo-7a8bbf0dd9baec1faffb463852d41a178585b38e.tar.gz
gentoo-7a8bbf0dd9baec1faffb463852d41a178585b38e.tar.bz2
gentoo-7a8bbf0dd9baec1faffb463852d41a178585b38e.zip
app-forensics/yara: drop 4.1.3, 4.2.0_rc1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/Manifest2
-rw-r--r--app-forensics/yara/yara-4.1.3.ebuild52
-rw-r--r--app-forensics/yara/yara-4.2.0_rc1.ebuild55
3 files changed, 0 insertions, 109 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 639cb3682cb2..4ccdfbf5fb21 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1,3 +1 @@
-DIST yara-4.1.3.tar.gz 936462 BLAKE2B abfdd5918abe3641056ccde3eebb754cbd66eff5569978d3b1aad5d925d62fcb96b1f7367d0d014dd165db8634418259667be3b2441f93e0848bfbd905ca32dd SHA512 1bfa1787c62dfd9a87fa8db5e8c2fa68f082ae66b16b5373bdcc6bc66b32016fcaffd4baa7e59a7c1f6d3426c972eca9cc22f70d475067d7557b1014a4ab65fc
DIST yara-4.2.0.tar.gz 1284059 BLAKE2B 735d161fde5f84199315f1ce6d31f1ad79488312bede85d2941a03cb97fe75c3c4db0b3cba75782d338a462d87e9d9ed57b393bbdb68decfb350a1bbd096258b SHA512 24ca707015c77d87126bcaac0991997f6b09403024765d615a06db47191a3f0177e1c1eb4a917ec8412876b61d28f4a708f36999ddd9214c3967968c71ae3b7c
-DIST yara-4.2.0_rc1.tar.gz 1283822 BLAKE2B d7bf869e670a0223895aac31df0dbe063d3f0110d1981ae8a42ab26726976790c744b522f13a6963f521310a281fab2b27d6336b23e504a4a9a3d414473ae452 SHA512 03bd09d7c020078946101854e68b7f9ca17c04f7a68624e9e15dc476fe209cc11b010108a0e7aea9746f05aabdbb8d6a6a2ffc54516eb9cb86f170c4259934df
diff --git a/app-forensics/yara/yara-4.1.3.ebuild b/app-forensics/yara/yara-4.1.3.ebuild
deleted file mode 100644
index e11e07efff40..000000000000
--- a/app-forensics/yara/yara-4.1.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="A malware identification and classification tool"
-HOMEPAGE="http://virustotal.github.io/yara/"
-SRC_URI="https://github.com/virustotal/yara/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/8"
-KEYWORDS="~amd64 ~x86"
-IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/openssl:=
- cuckoo? ( dev-libs/jansson:= )
- magic? ( sys-apps/file:= )
-"
-RDEPEND="${DEPEND}"
-PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable profiling) \
- $(use_enable cuckoo) \
- $(use_enable magic) \
- $(use_enable dotnet) \
- $(use_enable macho) \
- $(use_enable dex) \
- $(use_enable test static)
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- # TODO: Allow tests to work against dyn. lib rather than building
- # statically just for tests.
- find "${ED}" -name '*.a' -delete || die
-}
diff --git a/app-forensics/yara/yara-4.2.0_rc1.ebuild b/app-forensics/yara/yara-4.2.0_rc1.ebuild
deleted file mode 100644
index 8bac51561719..000000000000
--- a/app-forensics/yara/yara-4.2.0_rc1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="A malware identification and classification tool"
-HOMEPAGE="http://virustotal.github.io/yara/"
-SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${PV/_/-}"
-
-LICENSE="Apache-2.0"
-SLOT="0/8"
-if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~amd64 ~x86"
-fi
-IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/openssl:=
- cuckoo? ( dev-libs/jansson:= )
- magic? ( sys-apps/file:= )
-"
-RDEPEND="${DEPEND}"
-PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable profiling) \
- $(use_enable cuckoo) \
- $(use_enable magic) \
- $(use_enable dotnet) \
- $(use_enable macho) \
- $(use_enable dex) \
- $(use_enable test static)
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- # TODO: Allow tests to work against dyn. lib rather than building
- # statically just for tests.
- find "${ED}" -name '*.a' -delete || die
-}