summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2021-03-06 01:00:14 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2021-03-06 01:04:06 -0500
commit94f63965388a020f284c0bfb1644137f5f6c5690 (patch)
treeb31386a2ce84805f2ab654d5a984690e9cc840bf /app-forensics
parentsys-auth/pam_u2f: backport a patch to fix a build failure (diff)
downloadgentoo-94f63965388a020f284c0bfb1644137f5f6c5690.tar.gz
gentoo-94f63965388a020f284c0bfb1644137f5f6c5690.tar.bz2
gentoo-94f63965388a020f284c0bfb1644137f5f6c5690.zip
app-forensics/sleuthkit: prevent build the system from sourcing /usr/local
Closes: https://bugs.gentoo.org/774039 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/files/sleuthkit-4.10.1-exclude-usr-local.patch28
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.10.1-r1.ebuild (renamed from app-forensics/sleuthkit/sleuthkit-4.10.1.ebuild)3
2 files changed, 30 insertions, 1 deletions
diff --git a/app-forensics/sleuthkit/files/sleuthkit-4.10.1-exclude-usr-local.patch b/app-forensics/sleuthkit/files/sleuthkit-4.10.1-exclude-usr-local.patch
new file mode 100644
index 000000000000..256dc54548b0
--- /dev/null
+++ b/app-forensics/sleuthkit/files/sleuthkit-4.10.1-exclude-usr-local.patch
@@ -0,0 +1,28 @@
+From: Gokturk Yuksek <gokturk@gentoo.org>
+
+Do not allow the build system to use libs from /usr/local.
+
+Bug: https://bugs.gentoo.org/774039
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -92,19 +92,6 @@
+ dnl Enable multithreading by default in the presence of pthread
+ AS_IF([test "x$ax_pthread_ok" = "xyes" && test "x$enable_multithreading" != "xno"], [ax_multithread=yes], [ax_multithread=no])
+
+-case "$host" in
+-*-*-mingw*)
+- dnl Adding the native /usr/local is wrong for cross-compiling
+- ;;
+-*)
+- dnl Not all compilers include /usr/local in the include and link path
+- if test -d /usr/local/include; then
+- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+- LDFLAGS="$LDFLAGS -L/usr/local/lib"
+- fi
+- ;;
+-esac
+-
+ dnl Add enable/disable option
+ AC_ARG_ENABLE([java],
+ [AS_HELP_STRING([--disable-java], [Do not build the java bindings or jar file])])
diff --git a/app-forensics/sleuthkit/sleuthkit-4.10.1.ebuild b/app-forensics/sleuthkit/sleuthkit-4.10.1-r1.ebuild
index 0056a2c48726..ddb5a5ad0eea 100644
--- a/app-forensics/sleuthkit/sleuthkit-4.10.1.ebuild
+++ b/app-forensics/sleuthkit/sleuthkit-4.10.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -80,6 +80,7 @@ DEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-4.1.0-tools-shared-libs.patch
"${FILESDIR}"/${PN}-4.6.4-default-jar-location-fix.patch
+ "${FILESDIR}"/${PN}-4.10.1-exclude-usr-local.patch
)
src_unpack() {