summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-30 14:46:57 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-10-30 14:47:28 +0100
commita4720df6118669f20ee8ba061889454cd9edd405 (patch)
treee1b8b9e611dda44e62be787c98d3d2509f14b068 /app-forensics
parentapp-office/akonadi-server -> kde-apps/akonadi (diff)
downloadgentoo-a4720df6118669f20ee8ba061889454cd9edd405.tar.gz
gentoo-a4720df6118669f20ee8ba061889454cd9edd405.tar.bz2
gentoo-a4720df6118669f20ee8ba061889454cd9edd405.zip
app-forensics/chkrootkit: Bump to version 0.51
Permission kindly granted by Patrick. Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/chkrootkit/Manifest2
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.51.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-forensics/chkrootkit/Manifest b/app-forensics/chkrootkit/Manifest
index 12d104ecf767..11bdb721333f 100644
--- a/app-forensics/chkrootkit/Manifest
+++ b/app-forensics/chkrootkit/Manifest
@@ -2,3 +2,5 @@ DIST chkrootkit-0.49-gentoo.diff.bz2 5472 SHA256 85a01c8bb159420fc7681b5f3ec6529
DIST chkrootkit-0.49.tar.gz 39421 SHA256 ccb87be09e8923d51f450a167f484414f70c36c942f8ef5b9e5e4a69b7baa17f SHA512 b796547fc483635ff6ee4e953f7dda34913189459de05b547522b79f8edeef5adae72cc05515b8ff9382cbabffd93cae7d114a40636e14c55da513bb42b05909 WHIRLPOOL c94f96f185ae5f5dd038a7b2ffd9603ee8c0f2fcbaeb3eb73d20260898f1677a2c1aad5cd6a257b29ca540d02916dca59434ff10b807567447889cf23f65b25e
DIST chkrootkit-0.50-gentoo.diff.bz2 5010 SHA256 0b29ad086d0c75df6a0826bc8fd9046d5b1086173652af77f01991f367032779 SHA512 067a0a33fad2389a7ef942f76a63bed6c206d08576a77fd758ae171960804fb74d3164bc6eb582f5d8b722e9e863dc4380f5632940bc9a8c1821b46ed1062a50 WHIRLPOOL 4bc08be7be6d566bb2f52ece6c9010967c107696ce924461a4032947f66e848183921232f3f1a971cf6f932cbaad7ac9ce18af765837e3e69f7c0a57b39ceaed
DIST chkrootkit-0.50.tar.gz 38616 SHA256 9548fc922b0cb8ddf055faff4a4887f140a31c45f2f5e3aa64aad91ecfa56cc7 SHA512 9f26fd34e85b58b13dedc5f38a889ae258bb2c0f1ff40e99c149e23f93890e956f94204b1bb2241584454e99168c53b583f52777083454237f3ba343424dba1c WHIRLPOOL d6c6afe6a14e5a9a0331202b894ed5c3e43855e15605cc9a6cbf69dbd09f180754ee587cf4eba88cb0ceb4d7fcd9924f4f02110154450fd06e992fc1710b91d8
+DIST chkrootkit-0.51-gentoo.diff.xz 4708 SHA256 150ea7a343d93382be286ea649be2b6a0784be98da1757b86a30fe1ed1ee06f0 SHA512 13dca9c272d85d35d736e14896058612f62e1781aac034f06882fe63d956f074a3c67bf308c104f0080323bb127ba01373967b2c28481741d17d83310fe52dd0 WHIRLPOOL fa7a33fbca05f778ad2cc3694f93e04ee6b24f822f03e79ef0bb7c33049a447aac389ade66edecc8d6f79301c225573e50c465ca075a23e5c44904f817f97f10
+DIST chkrootkit-0.51.tar 174080 SHA256 d262b6c0292399c409a5d70f5a5646c76f5612c3bf416e4e21ba6cdecf9ae7c5 SHA512 adef6823d069b32305605d0eaa3d3701c6a87900646d9509cebe0fd8a2fec0523595d0dcb4576b32245e7638388d3b43858dbc42be68de9971ac8461fcfdeb34 WHIRLPOOL 9a379c73ced0eb5cf679cd99514d41b85a685b9cf54c23d7c682f5020b49d35c7bd79c01d0b029420dfaddd3a1de4a8765832879bc8ba9525f9dce30e9274e6c
diff --git a/app-forensics/chkrootkit/chkrootkit-0.51.ebuild b/app-forensics/chkrootkit/chkrootkit-0.51.ebuild
new file mode 100644
index 000000000000..ce547e6a219d
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.51.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to locally check for signs of a rootkit"
+HOMEPAGE="http://www.chkrootkit.org/"
+# Upstream named their *uncompressed* tarball .tar.gz (*sigh*)
+SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz -> ${P}.tar
+ https://dev.gentoo.org/~polynomial-c/${P}-gentoo.diff.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+cron"
+
+RDEPEND="cron? ( virtual/cron )"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-gentoo.diff
+)
+
+src_prepare() {
+ default
+ sed -e 's:/var/adm/:/var/log/:g' \
+ -i chklastlog.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" STRIP=true sense
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
+ dodoc ACKNOWLEDGMENTS README*
+
+ if use cron ; then
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/${PN}.cron ${PN}
+ fi
+}
+
+pkg_postinst() {
+ if use cron ; then
+ elog
+ elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog
+ fi
+
+ elog
+ elog "Some applications, such as portsentry, will cause chkrootkit"
+ elog "to produce false positives. Read the chkrootkit FAQ at"
+ elog "http://www.chkrootkit.org/ for more information."
+ elog
+}