summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/anthy-ss
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/anthy-ss')
-rw-r--r--app-i18n/anthy-ss/Manifest1
-rw-r--r--app-i18n/anthy-ss/anthy-ss-9026.ebuild73
-rw-r--r--app-i18n/anthy-ss/files/50anthy-gentoo.el4
-rw-r--r--app-i18n/anthy-ss/metadata.xml18
4 files changed, 96 insertions, 0 deletions
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
new file mode 100644
index 000000000000..ddd64ca3fc10
--- /dev/null
+++ b/app-i18n/anthy-ss/Manifest
@@ -0,0 +1 @@
+DIST anthy-9026.tar.gz 4064170 SHA256 1a4c2736b531dd088f1d8f22a67a87cfc29de23402c72e70d9e5bb160b448685 SHA512 00b99d5c2e2d91b21e86fc2fb3c46490f97aa20f2d91afb2ddbe59606c0b01da9199088a92119930d0f5b8e266f3314be3cceab3562b58684692090259bc2f79 WHIRLPOOL 6587d9914eede00ca541764a9ead6befd014f9c3bc72dc28e855bc1e50a4da0c616051d7e01c96e3d9ad6d34ab074017a64db41d8ee58d314a04ab2c3de74830
diff --git a/app-i18n/anthy-ss/anthy-ss-9026.ebuild b/app-i18n/anthy-ss/anthy-ss-9026.ebuild
new file mode 100644
index 000000000000..d5752624fcf9
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-9026.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit elisp-common eutils
+
+IUSE="emacs"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/25984/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="!app-i18n/anthy
+ emacs? ( virtual/emacs )"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ sed -i /placename/a"read ${cannadicdir}/nichan.ctd" \
+ mkworddic/dict.args.in
+ fi
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use emacs || myconf="EMACS=no"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
+
+ dodoc AUTHORS DIARY NEWS README ChangeLog
+
+ docinto doc
+ rm doc/Makefile*
+ dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/50anthy-gentoo.el b/app-i18n/anthy-ss/files/50anthy-gentoo.el
new file mode 100644
index 000000000000..2c3ed77062f7
--- /dev/null
+++ b/app-i18n/anthy-ss/files/50anthy-gentoo.el
@@ -0,0 +1,4 @@
+
+;;; anthy-ss site-lisp configuration
+
+(set-language-info "Japanese" 'input-method "japanese-anthy")
diff --git a/app-i18n/anthy-ss/metadata.xml b/app-i18n/anthy-ss/metadata.xml
new file mode 100644
index 000000000000..7deacf38f2b1
--- /dev/null
+++ b/app-i18n/anthy-ss/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <maintainer>
+ <email>hattya@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Anthy is a free and secure Japanese kana-kanji server. This ebuild
+ includes cannadic as a server-side dictionary, so you don't need any
+ extra package to run it. You can use anthy with app-i18n/jmode (XIM),
+ app-i18n/uim(XIM, GTK+ immodule) and emacs (to enable Anthy support
+ for emacs, build this package with emacs USE flag).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge-jp">anthy</remote-id>
+ </upstream>
+</pkgmetadata>