summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/fcitx-configtool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/fcitx-configtool')
-rw-r--r--app-i18n/fcitx-configtool/Manifest2
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild34
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild33
-rw-r--r--app-i18n/fcitx-configtool/metadata.xml11
4 files changed, 80 insertions, 0 deletions
diff --git a/app-i18n/fcitx-configtool/Manifest b/app-i18n/fcitx-configtool/Manifest
new file mode 100644
index 000000000000..1d391788deb7
--- /dev/null
+++ b/app-i18n/fcitx-configtool/Manifest
@@ -0,0 +1,2 @@
+DIST fcitx-configtool-0.4.6.tar.xz 41992 SHA256 8d64107f9f12b4f2cbd82e40b87a2dc4dc76d0ff854481c1103d5e9a2c2e129d SHA512 946bceb77fc6d14210154d9264c86d3333f910893cf3054f65eab72641421847e8ac003889b742f4c28f74c8ab1cfbcfb82abe35ea83ca2548cfc1decc92fc4c WHIRLPOOL 58f8a420f6c98cb6d710bd05d8ca2a3ca48a115015e6de98b105bf71b59bf3dab34eb63009d763dc7a3554fa6ec0b442e8bb277f890230dd94ec371397a6766c
+DIST fcitx-configtool-0.4.8.tar.xz 47196 SHA256 0ebc06d9d325fed096e9cb61fe53b82000d2de0e9aefe5945ba8f0aa2ca851ed SHA512 7b3c43b9d7d1dab04880effe6fc4e80e64c9bad34699c0c8d2992ec971605ef2eaa0b1fb13f71a582289c75560c3edc95af21f6413ac2bb594d5cdb31a0b4cb7 WHIRLPOOL a1817bcc9d6bdcd96e66dbe71d44cb66d6b66802e366b8f21d5f922495176463fc23adff2bbdbfb4003ddcef43839fab06715231fdaada8714eec1e3a073f18f
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild
new file mode 100644
index 000000000000..ebf428cbf88f
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A GTK+ GUI configuration tool for fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://fcitx.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE="gtk +gtk3"
+REQUIRED_USE="|| ( gtk gtk3 )"
+
+RDEPEND=">=app-i18n/fcitx-4.2.7
+ dev-libs/glib:2
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ app-text/iso-codes
+ dev-libs/libunique:1
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable gtk GTK2)
+ $(cmake-utils_use_enable gtk3 GTK3)"
+ cmake-utils_src_configure
+}
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild
new file mode 100644
index 000000000000..48ac139256ae
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A GTK+ GUI configuration tool for fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ppc64 ~x86"
+IUSE="gtk +gtk3"
+REQUIRED_USE="|| ( gtk gtk3 )"
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ dev-libs/glib:2
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ app-text/iso-codes
+ dev-libs/libunique:1
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable gtk GTK2)
+ $(cmake-utils_use_enable gtk3 GTK3)"
+ cmake-utils_src_configure
+}
diff --git a/app-i18n/fcitx-configtool/metadata.xml b/app-i18n/fcitx-configtool/metadata.xml
new file mode 100644
index 000000000000..4484e0f7375b
--- /dev/null
+++ b/app-i18n/fcitx-configtool/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <use>
+ <flag name="gtk3">Use GTK+3 instead of 2</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">fcitx</remote-id>
+ </upstream>
+</pkgmetadata>