summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-10-23 21:18:07 +0200
committerMike Gilbert <floppym@gentoo.org>2017-10-23 15:27:05 -0400
commitbab258f6ef4f46f5d9a9de79dae823b7858acdb8 (patch)
tree80071801d69720234cdd7c7e71e15b30e6f9ee62 /app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild
parentapp-i18n/fcitx-unikey: Fix LICENSE. (diff)
downloadgentoo-bab258f6ef4f46f5d9a9de79dae823b7858acdb8.tar.gz
gentoo-bab258f6ef4f46f5d9a9de79dae823b7858acdb8.tar.bz2
gentoo-bab258f6ef4f46f5d9a9de79dae823b7858acdb8.zip
app-i18n/fcitx-table-extra: Version bump (0.3.8).
Diffstat (limited to 'app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild')
-rw-r--r--app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild
new file mode 100644
index 000000000000..60a3f7c886a2
--- /dev/null
+++ b/app-i18n/fcitx-table-extra/fcitx-table-extra-0.3.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-table-extra"
+fi
+
+DESCRIPTION="Extra Chinese table input methods for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-table-extra"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4[table]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}