summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-09-15 11:00:35 +0200
committerMike Gilbert <floppym@gentoo.org>2016-09-15 10:45:24 -0400
commit9ab392629fa40a614bbc82c32c1b0bf2e0a796a8 (patch)
tree6844f52ec967c5e6c9f6048e94e754208ac268d5 /app-i18n/fcitx
parentsci-mathematics/rkward: version bump (diff)
downloadgentoo-9ab392629fa40a614bbc82c32c1b0bf2e0a796a8.tar.gz
gentoo-9ab392629fa40a614bbc82c32c1b0bf2e0a796a8.tar.bz2
gentoo-9ab392629fa40a614bbc82c32c1b0bf2e0a796a8.zip
app-i18n/fcitx: Use EAPI="6".
Diffstat (limited to 'app-i18n/fcitx')
-rw-r--r--app-i18n/fcitx/fcitx-4.2.9.1.ebuild2
-rw-r--r--app-i18n/fcitx/fcitx-9999.ebuild2
-rw-r--r--app-i18n/fcitx/files/fcitx-4.2.9.1-qt-4_ucs4.patch4
-rw-r--r--app-i18n/fcitx/files/fcitx-4.2.9.1-tray_icon.patch16
4 files changed, 12 insertions, 12 deletions
diff --git a/app-i18n/fcitx/fcitx-4.2.9.1.ebuild b/app-i18n/fcitx/fcitx-4.2.9.1.ebuild
index fe803d03e18f..1080af59cfe6 100644
--- a/app-i18n/fcitx/fcitx-4.2.9.1.ebuild
+++ b/app-i18n/fcitx/fcitx-4.2.9.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
inherit cmake-utils gnome2-utils multilib xdg
diff --git a/app-i18n/fcitx/fcitx-9999.ebuild b/app-i18n/fcitx/fcitx-9999.ebuild
index 10f01f0b9c0f..cc1201238b4e 100644
--- a/app-i18n/fcitx/fcitx-9999.ebuild
+++ b/app-i18n/fcitx/fcitx-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI="6"
inherit cmake-utils gnome2-utils multilib xdg
diff --git a/app-i18n/fcitx/files/fcitx-4.2.9.1-qt-4_ucs4.patch b/app-i18n/fcitx/files/fcitx-4.2.9.1-qt-4_ucs4.patch
index 2e114b087f25..e417a0615716 100644
--- a/app-i18n/fcitx/files/fcitx-4.2.9.1-qt-4_ucs4.patch
+++ b/app-i18n/fcitx/files/fcitx-4.2.9.1-qt-4_ucs4.patch
@@ -1,8 +1,8 @@
https://github.com/fcitx/fcitx/commit/14faccfbb0d87e06c25d182ae842808d18be3dc7
https://github.com/fcitx/fcitx/commit/216a09e3ec056f272eebfbe82809b803d86012cb
---- src/frontend/qt/qfcitxinputcontext.cpp
-+++ src/frontend/qt/qfcitxinputcontext.cpp
+--- /src/frontend/qt/qfcitxinputcontext.cpp
++++ /src/frontend/qt/qfcitxinputcontext.cpp
@@ -232,6 +232,20 @@
anchor = var2.toInt();
else
diff --git a/app-i18n/fcitx/files/fcitx-4.2.9.1-tray_icon.patch b/app-i18n/fcitx/files/fcitx-4.2.9.1-tray_icon.patch
index 4f04f5ea423d..7bfbc6e9ade0 100644
--- a/app-i18n/fcitx/files/fcitx-4.2.9.1-tray_icon.patch
+++ b/app-i18n/fcitx/files/fcitx-4.2.9.1-tray_icon.patch
@@ -4,8 +4,8 @@ https://github.com/fcitx/fcitx/commit/353683e29be4ef26409b9a05e0cb647a5180fa8c
https://github.com/fcitx/fcitx/commit/fe2732db27a1c2e183400ceeb3283559e10a4ca8
https://github.com/fcitx/fcitx/commit/440c431d29876a8e4871159d289bc9a573f9a41b
---- src/module/notificationitem/notificationitem.c
-+++ src/module/notificationitem/notificationitem.c
+--- /src/module/notificationitem/notificationitem.c
++++ /src/module/notificationitem/notificationitem.c
@@ -565,8 +565,17 @@
boolean FcitxNotificationItemEnable(FcitxNotificationItem* notificationitem, FcitxNotificationItemAvailableCallback callback, void* data)
@@ -25,8 +25,8 @@ https://github.com/fcitx/fcitx/commit/440c431d29876a8e4871159d289bc9a573f9a41b
if (notificationitem->serviceName) {
FcitxLog(ERROR, "This should not happen, please report bug.");
return false;
---- src/ui/classic/TrayWindow.c
-+++ src/ui/classic/TrayWindow.c
+--- /src/ui/classic/TrayWindow.c
++++ /src/ui/classic/TrayWindow.c
@@ -48,7 +48,7 @@
Display *dpy = classicui->dpy;
int iScreen = classicui->iScreen;
@@ -100,8 +100,8 @@ https://github.com/fcitx/fcitx/commit/440c431d29876a8e4871159d289bc9a573f9a41b
}
return false;
}
---- src/ui/classic/classicui.c
-+++ src/ui/classic/classicui.c
+--- /src/ui/classic/classicui.c
++++ /src/ui/classic/classicui.c
@@ -168,7 +168,7 @@
void ClassicUIDelayedInitTray(void* arg) {
FcitxClassicUI* classicui = (FcitxClassicUI*) arg;
@@ -120,8 +120,8 @@ https://github.com/fcitx/fcitx/commit/440c431d29876a8e4871159d289bc9a573f9a41b
return;
if (!classicui->trayWindow->bTrayMapped) {
---- src/ui/classic/tray.c
-+++ src/ui/classic/tray.c
+--- /src/ui/classic/tray.c
++++ /src/ui/classic/tray.c
@@ -106,8 +106,9 @@
XWindowAttributes attr;