summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-08-27 22:53:27 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-08-27 22:53:27 +0900
commit83cfedf3349c903e837dee8c523f8ea2eabe5e83 (patch)
tree4f7314c1eab10d31a3a96441f5ac31c501aa33d1 /app-i18n/ibus-anthy
parentdev-php/pecl-eio: Version bump for 3.0.0_rc2 (diff)
downloadgentoo-83cfedf3349c903e837dee8c523f8ea2eabe5e83.tar.gz
gentoo-83cfedf3349c903e837dee8c523f8ea2eabe5e83.tar.bz2
gentoo-83cfedf3349c903e837dee8c523f8ea2eabe5e83.zip
app-i18n/ibus-anthy: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/Manifest1
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.5.12.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-i18n/ibus-anthy/Manifest b/app-i18n/ibus-anthy/Manifest
index cccf13fccfe0..d8a7a88df00a 100644
--- a/app-i18n/ibus-anthy/Manifest
+++ b/app-i18n/ibus-anthy/Manifest
@@ -1,2 +1,3 @@
DIST ibus-anthy-1.5.10.tar.gz 758528 BLAKE2B 39496f5c3a5f2038f3f81e09504e472a32da85f27701741cbe77b576afcd8685c4f2209aaf24ef84420cbeec1614b251d2903c1ea4e7175a1014f92615399847 SHA512 963b1dfba18259aad2296c10de35f9f321b0169d6f85afa058ed57b6894fe4e1d44514ffadeee3c3108aac77f54aa645096ddf4bdb353fafaedb83d27d8c5d47
DIST ibus-anthy-1.5.11.tar.gz 809725 BLAKE2B b12139e208c401e3fdda0d3a184b0246d039e077b827d1aeb2da20470deeb62551026c68ba39c289e7876467147a6ba93d318d0582a9b45866c2f5a4f52e85aa SHA512 2ac85bf4ddba56e3f84c3732082b3b63a07175ea712aad2865de4f87b8c0967da303ee1edccbed0890095e8ddab10e58307a47b72ee11b51de3927fdb9e72418
+DIST ibus-anthy-1.5.12.tar.gz 825323 BLAKE2B 4d81a5885e4ad6cfc7a10ecb61bf998a76c24049e58841f84ed31f45a8ab5e91cfd2c60be3a66008f97317047487bedcf956b9126fa17602c6f8a29950687b84 SHA512 6950a2865e4753831f8918f4a5926571bc8304454b6368662ef56a6fb11a60f0675e3d589108ebfd38cb5d193f7b61053a10baa6dad23adad67b3b3fc58760e8
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.5.12.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.5.12.ebuild
new file mode 100644
index 000000000000..553ff6d1baf3
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.5.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Japanese Anthy engine for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/ibus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/anthy
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ default
+ gnome2_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --enable-private-png \
+ --with-layout=default \
+ --with-python=${EPYTHON}
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ python_optimize
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version app-dicts/kasumi; then
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}