summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-09-20 11:26:06 +0800
committerYixun Lan <dlan@gentoo.org>2016-09-20 11:28:20 +0800
commitc0555385075e553f95dc7e9517aa614bc718f5f9 (patch)
tree76a2fc8fbc360d4d7e550a7d337ebb1377a4f925 /app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
parentx11-drivers/xf86-video-intel: fix for bug #582910 for latest stable and testi... (diff)
downloadgentoo-c0555385075e553f95dc7e9517aa614bc718f5f9.tar.gz
gentoo-c0555385075e553f95dc7e9517aa614bc718f5f9.tar.bz2
gentoo-c0555385075e553f95dc7e9517aa614bc718f5f9.zip
app-i18n/ibus-qt: don't get_libdir called in global scope
Gentoo-Bug: 593390 Package-Manager: portage-2.3.0
Diffstat (limited to 'app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild')
-rw-r--r--app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild b/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
index cf130f74ac80..4a7674e98244 100644
--- a/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
+++ b/app-i18n/ibus-qt/ibus-qt-1.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,7 +29,11 @@ DOCS="AUTHORS README TODO"
PATCHES=( "${FILESDIR}"/${PN}-1.3-doc.patch )
-mycmakeargs="-DLIBDIR=$(get_libdir) all"
+src_configure() {
+ local mycmakeargs=( -DLIBDIR=$(get_libdir) all )
+
+ cmake-utils_src_configure
+}
src_compile() {
cmake-utils_src_compile