summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-08-06 10:00:14 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-08-06 10:00:14 +0900
commit22270eb93a2ce70969b4963716cc90715c52e7ce (patch)
treeb779d19c4acb9bbf265431a2149a51cd5f235de2 /app-i18n/ibus-table
parentdev-libs/libutf8proc: set QA_PKGCONFIG_VERSION (diff)
downloadgentoo-22270eb93a2ce70969b4963716cc90715c52e7ce.tar.gz
gentoo-22270eb93a2ce70969b4963716cc90715c52e7ce.tar.bz2
gentoo-22270eb93a2ce70969b4963716cc90715c52e7ce.zip
app-i18n/ibus-table: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.16.10.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index aa5795ad8217..dd60b54f7771 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1 +1,2 @@
+DIST ibus-table-1.16.10.tar.gz 1518611 BLAKE2B 610f4448bb59cffef4e11b069dc5d3f6aa0eadffe6f6af7da07b2b24da0969dc63dc05717694c7b61ac5e18c14433b4af6a111a7076bd8a69871e70ea8fe357e SHA512 3e3dc4ec6aea974d7b0f171375448090e117c70a3ba3d1b6c218db481725e58c65adce55839f826ec274d33f926377d0390bcd505af1911c5b9f68910d0c3497
DIST ibus-table-1.16.9.tar.gz 1474440 BLAKE2B 8380c9549e4295850c81279e73b774beea610ebb632bc8a04fe0ce37a02c702652c0ec49ed3596851e05d2f151320daf60eb2631c8bbe439aee8c7e2834398f5 SHA512 840de16f62820456812c036ed84f99900d2d49885a9a6131da97efbec149ea426ab4a966541b16a18dbcedf38b6f78803b3fb04a5134258bb3796d3b9caf0b08
diff --git a/app-i18n/ibus-table/ibus-table-1.16.10.ebuild b/app-i18n/ibus-table/ibus-table-1.16.10.ebuild
new file mode 100644
index 000000000000..7314f41b0540
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.16.10.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}