summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-05-08 17:36:40 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-05-08 17:36:40 +0900
commit55d24b026f79e1cd15fe9fb1c3b82be9a41f70d3 (patch)
tree37e3c02409a8bcd2deefabf8690171496ca7b8dd /app-i18n/ibus-table
parentmedia-libs/libepoxy: keyword 1.5.10 for ~loong (diff)
downloadgentoo-55d24b026f79e1cd15fe9fb1c3b82be9a41f70d3.tar.gz
gentoo-55d24b026f79e1cd15fe9fb1c3b82be9a41f70d3.tar.bz2
gentoo-55d24b026f79e1cd15fe9fb1c3b82be9a41f70d3.zip
app-i18n/ibus-table: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-table')
-rw-r--r--app-i18n/ibus-table/Manifest1
-rw-r--r--app-i18n/ibus-table/ibus-table-1.16.8.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-i18n/ibus-table/Manifest b/app-i18n/ibus-table/Manifest
index 0f6b2cc10ad9..3d6bc3749242 100644
--- a/app-i18n/ibus-table/Manifest
+++ b/app-i18n/ibus-table/Manifest
@@ -1,2 +1,3 @@
DIST ibus-table-1.14.1.tar.gz 1451943 BLAKE2B e8fc54daf89aaee813de6788bef9f56a654ffdf4751acf3e2f622d971134c3aba906ca2b106f51b2fa305b8c65fb4db862f57f5f9e3e82a569c5a72e3017e627 SHA512 a658c2d370d173d2fe2f38c02c6b822a17771754ac98a856f954c4c998e90a857f9d54ed652c74159af9545d445001d202e7b5578e7694f8767f928b42db9055
DIST ibus-table-1.16.7.tar.gz 1463213 BLAKE2B 2d3eb68570c834f668f8d8f50ea4fc79cb1def331405f136000dda37d9be0150a442e2b92a29610632eefde42089f6c5b782ea63fa1d9b5fde9443419a6831cf SHA512 6dc08df4c5e7216b3b9e366c404dd6d89566937f83f58074aed1c5c925bc411568855ac08a8edab306b4b535da428ae660d4876a35e546aad75ede01aa608ee3
+DIST ibus-table-1.16.8.tar.gz 1468647 BLAKE2B acfb0cfce0e029abd55bc4465cac408be59a834761b2f1f5eca8798a11109bb9e885d17d1a1d171de5c7556308b1d7314fe97454a3a1fbd2494f492698ccc5ec SHA512 086650238b170db69ace0faacea6c8c9c03c099c59313cb7663b573f17bd4e9df9309dc9132708a89d6ce5cf00f4846ba50dab3462f31293b891487f1635aab2
diff --git a/app-i18n/ibus-table/ibus-table-1.16.8.ebuild b/app-i18n/ibus-table/ibus-table-1.16.8.ebuild
new file mode 100644
index 000000000000..7314f41b0540
--- /dev/null
+++ b/app-i18n/ibus-table/ibus-table-1.16.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Tables engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/kaio/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ virtual/libiconv
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ default
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}