summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-23 21:37:47 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-23 21:37:47 +0900
commit67718a84fd0403c2b36fe8225302dcbfead1de57 (patch)
tree2d16b4c14b2afe7c8e2375f661b638b9fc5262f2 /app-i18n/im-canna
parentapp-i18n/im-canna: update to EAPI 6 (diff)
downloadgentoo-67718a84fd0403c2b36fe8225302dcbfead1de57.tar.gz
gentoo-67718a84fd0403c2b36fe8225302dcbfead1de57.tar.bz2
gentoo-67718a84fd0403c2b36fe8225302dcbfead1de57.zip
app-i18n/im-canna: fix immodules path
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/im-canna')
-rw-r--r--app-i18n/im-canna/files/im-canna-gentoo.patch35
-rw-r--r--app-i18n/im-canna/im-canna-0.3.2.2-r1.ebuild43
2 files changed, 78 insertions, 0 deletions
diff --git a/app-i18n/im-canna/files/im-canna-gentoo.patch b/app-i18n/im-canna/files/im-canna-gentoo.patch
new file mode 100644
index 000000000000..959e8697eb82
--- /dev/null
+++ b/app-i18n/im-canna/files/im-canna-gentoo.patch
@@ -0,0 +1,35 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,4 @@
+-moduledir = ${libdir}/gtk-2.0/2.4.0/immodules
++moduledir = ${libdir}/gtk-2.0/${GTK_BINARY_VERSION}/immodules
+ ## Makefile.am for gtk+/modules/input
+ if PLATFORM_WIN32
+ no_undefined = -no-undefined
+@@ -6,11 +6,11 @@
+
+ SUBDIRS = po
+
+-INCLUDES = @GTK_DEP_CFLAGS@ -I/usr/include/canna -DIM_LOCALEDIR=\"${datadir}/locale\"
++INCLUDES = @GTK_DEP_CFLAGS@ -DIM_LOCALEDIR=\"${datadir}/locale\"
+
+ DEPS =
+
+-LDADDS = @GTK_DEP_LIBS@ -lcanna
++LDADDS = @GTK_DEP_LIBS@
+
+ EXTRA_DIST= \
+ im-canna.spec \
+--- a/configure.in
++++ b/configure.in
+@@ -21,8 +21,10 @@
+
+ GTK_DEP_CFLAGS=`pkg-config gtk+-2.0 --cflags`
+ GTK_DEP_LIBS=`pkg-config gtk+-2.0 --libs`
++GTK_BINARY_VERSION=`pkg-config gtk+-2.0 --variable=gtk_binary_version`
+ AC_SUBST(GTK_DEP_CFLAGS)
+ AC_SUBST(GTK_DEP_LIBS)
++AC_SUBST(GTK_BINARY_VERSION)
+
+ LT_RELEASE=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION
+ LT_CURRENT=2
diff --git a/app-i18n/im-canna/im-canna-0.3.2.2-r1.ebuild b/app-i18n/im-canna/im-canna-0.3.2.2-r1.ebuild
new file mode 100644
index 000000000000..673a3b973445
--- /dev/null
+++ b/app-i18n/im-canna/im-canna-0.3.2.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools gnome2-utils ltprune
+
+DESCRIPTION="Japanese Canna input method module for GTK+2"
+HOMEPAGE="http://bonobo.gnome.gr.jp/~nakai/immodule/"
+SRC_URI="http://bonobo.gnome.gr.jp/~nakai/immodule/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="app-i18n/canna
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
+
+src_prepare() {
+ default
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
+
+pkg_postinst() {
+ gnome2_query_immodules_gtk2
+}
+
+pkg_postrm() {
+ gnome2_query_immodules_gtk2
+}